-   Linux - Wireless Networking (
-   -   3 minor wifi problems in Slackware 12.1 (

gregorian 07-30-2009 08:39 AM

3 minor wifi problems in Slackware 12.1
I'm running Slackware 12.1 on my laptop. I've installed the drivers for my wireless card and I know they're the correct ones since I was able to connect to the wifi network using Fedora. I also know I'm not out of range since Windows (and sometimes Slackware) marks the connection as strong.

My difficulty with Slackware comprises of 3 seemingly minor problems:

1. The wireless indicator (light) on my laptop does not always glow. It usually lights up during startup. If it doesn't, there's nothing I can do about it except continuously restart the computer and see if I can get lucky. Using KWiFiManager to disable and enable the radio doesn't turn on the light (only in this case).

KWiFiManager uses the following commands to accomplish this:
iwconfig wlan0 txpower off
iwconfig wlan0 txpower on

I would like to know how to turn on the light if it does not turn on during startup.

2. Assuming I do not face problem 1, I get the following screen.
Attachment 1111
Scanning for networks does not help.

I would like to know how to obtain the window in the next screenshot.

3. This appears when I've been magnanimous for the whole week. I rarely obtain the following screen:

Attachment 1110

But I can't even ping a website. I'm guessing that's because my dhcpd doesn't run for my wireless connection. During bootup it mentions polling for a server on eth0 (which isn't there currently). There's no mention of wlan0. It's probably because I didn't have wifi when I installed Slackware. But this is just my conjecture, so please feel to ignore it if you think this isn't the cause.

Thank you very much for your help.

business_kid 07-31-2009 12:17 PM

Briefly - Beware of a 'network switching' option in the bios which turns off wifi when your eth0 is in use, and vice versa. I set USEDHCP="no" on eth0 and that keeps it out of the way. If I have a wired connection, I can simply type
dhcpcd eth0

Also make sure You are within range, and on an uncrowded channel. Try iwlist wlan0 scan |less as root and see what it shows. I had somebody complaining to me about an rf device, but he was trying to get reception through 2 feet (0.7 metre) walls :-(.

gregorian 07-31-2009 11:00 PM

Thank you for your response! I've changed the settings for eth0 in rc.inet1.conf and set corresponding settings for wlan0, based on the information I got by running ipconfig in Windows. That DHCP doesn't come for eth0 anymore. I'm within range - I'm using Windows right now. I don't understand the random behaviour of my light, and assuming the light is on; why I don't always pick up the network.

gregorian 08-01-2009 01:10 AM

It might be an improvement, but the light glows for a short while from the starting to the termination of the rc.inet1 script.

su -c "/etc/rc.d/rc.inet1 wlan0_start"

/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
dhcpcd: MAC address = 00:14:a5:22:af:a8

Abridged rc.inet1.conf:


WLAN_RATE[4]="54M auto"

I edited the file considering the output I got from ipconfig -a (abridged) in Windows.

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
        Physical Address. . . . . . . . . : 00-14-A5-22-AF-A8
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . :
        Subnet Mask . . . . . . . . . . . :
        Default Gateway . . . . . . . . . :
        DHCP Server . . . . . . . . . . . :
        DNS Servers . . . . . . . . . . . :
        Lease Obtained. . . . . . . . . . : Saturday, August 01, 2009 8:04:39 AM
        Lease Expires . . . . . . . . . . : Sunday, August 02, 2009 8:04:39 AM

business_kid 08-01-2009 04:03 AM

Don't set IP adresses or gateway in DHCP settings. The DHCP sets them and tells you. That's the waay it works. also, kill dhcp and then try

dhcpcd wlan0

As you see, that sets nothing. Better make sure no dhcp is running first. You can get wpa_supplicant into the picture by first starting
wpa_supplicant -dW <your options> > file 2>&1

Then you can look at the file to examine what went wrong.

gregorian 08-01-2009 07:08 AM

Will dhpcd wlan0 work when my wifi light is off? As I mentioned, it doesn't always glow during startup. But it glows for a while when I run the rc.inet1 script.

I had not specified the DHCP IP address in the rc.inet1.conf file initially, but that also doesn't work. Is the wpa_supplicant mandatory for all networks? If it isn't how do I find out which networks don't require it? I don't know what options I'm supposed to set (or even if I'm supposed to set) that's why I didn't touch it.

gregorian 08-02-2009 06:41 AM

I seem to have figured out the solution to the first problem. I just need to use ifconfig wlan0 down followed by ifconfig wlan0 up about three times in succession (don't know why).

But even then I can't get a signal. I rarely get a signal. I want to know how to connect to my access point. "sudo iwlist wlan0 scan" (omitting sudo will bring up only old results) will not bring up results even when I do get a signal in Linux.

I tried running dhcpcd wlan0 but it gave the same results.
EDIT: I'm starting a new thread because I actually managed to get an IP, and the problem appears to be that of random behaviour.

All times are GMT -5. The time now is 11:06 PM.