-   Linux - Virtualization and Cloud (
-   -   vmware workstation 7.1.2 - Can't completely uninstall it on slackware 13.37 (

zyz 08-16-2011 07:24 PM

vmware workstation 7.1.2 - Can't completely uninstall it on slackware 13.37
Hi guys,

I can't fully uninstall vmware workstation from slackware 13.37.Have already tried:

./vmware-workstation-full-7.1.2-301548.i386.bundle --console -l -uninstall-component=vmware-workstation

vmware-installer -u vmware-workstation

the vmware-workstation isn't executable anymore but there are alot of components vmware-* in the system. How do i get rid of them and make a full uninstall?


NullNullNix 09-30-2011 04:20 AM

Perhaps this may inspire you
I just found the following on the web. Although I realize that these steps are for an older version of VMWare Workstation), it might be of some use. Note: I haven't tried this myself (I am trying to get version 8.00 of Workstation working on Slackware 13.37_x64


When I try to install VMware Workstation 3.2 on my Linux host, I get an error
message that says a VMware product is already installed. I cannot find any such
installation. How do I remove previous installations manually?

To manually uninstall VMware Workstation 3.x, follow the steps below.
Note: The directories listed in steps 5 and 6 are correct for Red Hat Linux 6.x. If you
are running a different distribution, check for the correct init path by using this
ls -al /etc/rc.d/rc*.d/*vmware
Substitute the correct path in steps 5 and 6.
1. Log in as root.
2. cd /lib/modules/misc
3. mv vm* /tmp (assuming that you have a /tmp directory)
4. Run rmmod for each module:
rmmod vmnet.o
rmmod vmmon.o
rmmod vmppuser.o
5. rm /etc/rc.d/init.d/rc5.d/*vmware
6. rm /etc/rc.d/init.d/rc6.d/*vmware
7. rm -rf /etc/vmware
8. rm /usr/bin/vmware*
9. rm /usr/bin/vmnet*
If you installed VMware Workstation from the RPM package, you must also take the
following steps to remove VMware from your RPM database.
First run:
rpm -qa |grep VMware
This returns <packagename>.
Then run:
rpm --erase --nodeps <packagename>


All times are GMT -5. The time now is 09:30 AM.