-   Linux - Virtualization and Cloud (
-   -   virtualbox vboxdrv problem on Slackware 13.37 (

joao 10-12-2011 03:33 PM

virtualbox vboxdrv problem on Slackware 13.37
Hi. Trying to run virtualbox on Salix OS (Slackware) 13.37. Have already built and installed virtualbox 4.0.8 and virtualbox-kernel from slackbuilds.

When I run


/etc/rc.d/rc.vboxdrv setup
it says


Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules ...done.
Removing old VirtualBox pci kernel module ...done.
Removing old VirtualBox netadp kernel module ...done.
Removing old VirtualBox netflt kernel module ...done.
Removing old VirtualBox kernel module ...done.
Trying to register the VirtualBox kernel modules using DKMS ...failed!
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...done.
Starting VirtualBox kernel modules ...failed!
  (modprobe vboxdrv failed. Please use 'dmesg' to find out why)

and at the end of dmesg there is


vboxdrv: version magic ' SMP mod_unload 686 ' should be ' mod_unload 486 '
I think it means that it is trying to use 64 bit instead of 32 but I don't know what to do about it. I have already installed kernel-source

I'm am trying to do this because when I run virtualbox I get:


WARNING: The vboxdrv kernel module is not loaded. Either there is no module
        available for the current kernel ( or it failed to
        load. Please recompile the kernel module and install it by

          sudo /etc/init.d/vboxdrv setup

        You will not be able to start VMs until this problem is fixed.
Qt WARNING: Object::connect: No such signal QNetworkReplyImpl::sslErrors(QList<QSslError>)

Ian John Locke II 10-12-2011 06:56 PM

First I have to ask a stupid question, are you in fact running /etc/init.d/vboxdrv setup with sudo or after logging into root? If not, try that first.

x86_64 is the 64 bit architecture, not i686. Just informational.

joao 10-13-2011 01:24 PM

I'm already running the install and setup as root

All times are GMT -5. The time now is 08:56 AM.