LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices


Reply
  Search this Thread
Old 09-19-2011, 02:31 PM   #1
coolpraz
Member
 
Registered: Feb 2010
Posts: 35

Rep: Reputation: 0
Virtual box undefine error


i am new to linux and i install virtual box 4.1.2 in my RHEL6, it installed sucessfully and also i install DKMS, and execute the /etc/init.d/vboxdrv setup. it's show that everything ok but when i try to run vbox its show the error

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZNK16QAbstractSpinBox16inputMethodQueryEN2Qt16InputMethodQueryE

Please help me
 
Old 09-19-2011, 03:45 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Hi there,

I think the following links will help you out:

http://forums.virtualbox.org/viewtop...+symbol#p55521

http://forums.virtualbox.org/viewtopic.php?f=2&t=15442
 
Old 09-19-2011, 03:55 PM   #3
coolpraz
Member
 
Registered: Feb 2010
Posts: 35

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by T3RM1NVT0R View Post
thank T3RM1NVT0R but this link explaining about

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libQtGui.so.4: undefined symbol: _ZN23QCoreApplicationPrivate19checkReceiverThreadE P7QObject

and also talking about reinstalling qt packet but i already done that, and again same problem

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZNK16QAbstractSpinBox16inputMethodQueryEN2Qt16InputMethodQueryE
 
Old 09-19-2011, 04:13 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Alright.

1. Which version of virtual box you have installed?

2. Was there any errors during the install?

3. Are you trying to launch virtual box with regular user account or as root?

4. From where you have download virtual box?
 
Old 09-19-2011, 04:24 PM   #5
coolpraz
Member
 
Registered: Feb 2010
Posts: 35

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by T3RM1NVT0R View Post
Alright.

1. Which version of virtual box you have installed?

2. Was there any errors during the install?

3. Are you trying to launch virtual box with regular user account or as root?

4. From where you have download virtual box?

1. I have installed VirtualBox-4.1-4.1.2_73507_rhel6-1.x86_64.rpm

2. No there were no error during installation

3. I have tryed both regular and root in both mode same problem

4. I have downloaded it from www.virtualbox.org
 
Old 09-19-2011, 04:33 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
When you try to start Virtual box does that message comes up on the terminal or you have pasted it from /var/log/messages. If it comes on the terminal itself please paste the output of
Code:
tail /var/log/messages
Paste the output of the following commands as well:

1. uname -a
2. cat /proc/cpuinfo

I think you have downloaded the following package:

Red Hat Enterprise Linux 6 ("RHEL6") / Oracle Linux 6 ("OL6") i386 | AMD64

Let me know if you have downloaded the i386 one or AMD64?
 
Old 09-19-2011, 04:41 PM   #7
coolpraz
Member
 
Registered: Feb 2010
Posts: 35

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by T3RM1NVT0R View Post
When you try to start Virtual box does that message comes up on the terminal or you have pasted it from /var/log/messages. If it comes on the terminal itself please paste the output of
Code:
tail /var/log/messages
Paste the output of the following commands as well:

1. uname -a
2. cat /proc/cpuinfo

I think you have downloaded the following package:

Red Hat Enterprise Linux 6 ("RHEL6") / Oracle Linux 6 ("OL6") i386 | AMD64

Let me know if you have downloaded the i386 one or AMD64?

The message come up from terminal, the message from tail /var/log/messages is

Sep 20 01:49:52 coolpraz yum: Installed: libXt-devel-1.0.7-1.el6.x86_64
Sep 20 01:49:52 coolpraz yum: Installed: libXcursor-devel-1.1.10-2.el6.x86_64
Sep 20 01:49:52 coolpraz yum: Installed: libXdamage-devel-1.1.2-1.el6.x86_64
Sep 20 01:49:52 coolpraz yum: Installed: libXrandr-devel-1.3.0-4.el6.x86_64
Sep 20 01:49:52 coolpraz yum: Installed: libXft-devel-2.1.13-4.1.el6.x86_64
Sep 20 01:49:53 coolpraz yum: Installed: libXinerama-devel-1.1-1.el6.x86_64
Sep 20 01:49:53 coolpraz yum: Installed: libXxf86vm-devel-1.1.0-1.el6.x86_64
Sep 20 01:49:53 coolpraz yum: Installed: mesa-libGL-devel-7.7-2.el6.x86_64
Sep 20 01:49:54 coolpraz yum: Installed: mesa-libGLU-devel-7.7-2.el6.x86_64
Sep 20 01:49:58 coolpraz yum: Installed: qt3-devel-3.3.8b-29.el6.x86_64

1. output of uname -a is
Linux coolpraz.com 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

2. the output of cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz
stepping : 5
cpu MHz : 1200.000
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm arat tpr_shadow vnmi flexpriority ept vpid
bogomips : 6119.03
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz
stepping : 5
cpu MHz : 1200.000
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 2
apicid : 4
initial apicid : 4
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm arat tpr_shadow vnmi flexpriority ept vpid
bogomips : 6117.70
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz
stepping : 5
cpu MHz : 1200.000
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm arat tpr_shadow vnmi flexpriority ept vpid
bogomips : 6117.66
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz
stepping : 5
cpu MHz : 1200.000
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 2
apicid : 5
initial apicid : 5
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm arat tpr_shadow vnmi flexpriority ept vpid
bogomips : 6117.67
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:


i have downloaded AMD64 version

Last edited by coolpraz; 09-19-2011 at 04:50 PM.
 
Old 09-19-2011, 04:57 PM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

From the error message it appears that it is looking for specific input method and instead it is receiving a wrong method. Did you read the technical notes before installing it?

Here it is you can read them: http://www.virtualbox.org/wiki/Linux...20instructions

You can read the above and once you are sure that you fulfil the requirement you can give re-install a try.

You didnt mention which VirtualBox package you downloaded i386 or AMD64?
 
Old 09-19-2011, 05:03 PM   #9
coolpraz
Member
 
Registered: Feb 2010
Posts: 35

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by T3RM1NVT0R View Post
From the error message it appears that it is looking for specific input method and instead it is receiving a wrong method. Did you read the technical notes before installing it?

Here it is you can read them: http://www.virtualbox.org/wiki/Linux...20instructions

You can read the above and once you are sure that you fulfil the requirement you can give re-install a try.

You didnt mention which VirtualBox package you downloaded i386 or AMD64?
I have Downloaded AMD64 bit version because my CPU is 64 bit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in execute games in virtual box FinalRebel Linux - Software 3 09-07-2009 01:06 PM
Sun xVM Virtual Box error with ubuntu 8.10? tysonmax20042003 Linux - General 5 02-01-2009 01:13 PM
virtual box gives error deathalele Linux - Software 5 01-26-2009 01:22 PM
virtual box error Mr.mick-duck Mandriva 4 03-16-2008 04:13 AM
I get an error message while trying to install vb (Virtual Box) thewhitelion Linux - Software 1 04-04-2007 03:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud

All times are GMT -5. The time now is 07:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration