-   Linux - Virtualization and Cloud (
-   -   virt-install: kickstarting F17 from local ftp (

brianmcgee 06-13-2012 08:05 AM

virt-install: kickstarting F17 from local ftp
The following command worked with Fedora 16 to install a virtual machine:


#/usr/bin/virt-install --vnc --noautoconsole
--ram=768 --arch=i386 --vcpus=1 --os-type=linux --os-variant=rhel6 --hvm
--accelerate --disk=/dev/vgsystem/ -m
52:54:00:42:2C:C4 -w bridge=virbr0
ip= netmask= gateway=
dns= noipv6 s=100'

With Fedora 17 this fails. Maybe anaconda or the now dracut based initramfs does not handle the kernel parameters correctly that virt-install creates from the selected options.

I receive the following error message and a kernel panic just after the virtual machine booted:


FATAL: Please supply bootdev argument for multiple ip= lines
I also tried the 'ip=<ip>::<gw>:<nm>[:<dev>]' method to configure the
network interface the dracut way:


# /usr/bin/virt-install --vnc --noautoconsole
--ram=1024 --arch=i386 --vcpus=1 --os-type=linux --os-variant=rhel6
--hvm --accelerate --disk=/dev/vgsystem/ -m
52:54:00:42:89:08 -w bridge=virbr0
nameserver= noipv6 s=100'

With this command the virtual machine boots and drops to a dracut debug
shell. However no network interface gets configured and I receive the
following messages:


dracut Warning: Unable to process initqueue
dracut Warning: /dev/root does not exist

Could someone please enlighten me, how I may automatically kickstart my
test box with Fedora 17?

I've already asked the same question on the Fedora Users mailinglist but did not receive any hints. I've searched the Bugzilla but mostly found unrelated issues...

joshmule 06-28-2012 03:55 PM

I'm having a similar problem, but without static IP addresses. Try removing all network args from your Fedora 15 install, it should work with DHCP that libvirt provides. If so, try F17... I'll bet you get the same error that you do now.

joshmule 06-28-2012 05:31 PM

I still think it is not IP related in your case, but try using this ip= syntax:


That appears to be more correct per the new dracut docs.

BDJCL 07-05-2012 11:43 AM

It would be a bit easier if you went through the 'virt-install --prompt' method.

All times are GMT -5. The time now is 08:50 AM.