-   Linux - Virtualization and Cloud (
-   -   snowflock installation on fedora 10, machine unable to boot after I reboot (

Shashaa 11-13-2012 04:56 PM

snowflock installation on fedora 10, machine unable to boot after I reboot
Hi Folks,

I booted fedora 10 on my machine and installed snowflock using the manual here
Here are the steps I follwed
1) rpm -Uvh snowflock.rpm
2) disabled selinux
3) stopped iptables service
4) rebooted the system

while booting up I see the following error message:

mount: error mounting/dev/root on /sysroot as ext3:

and the system gets stuck and unable to proceed further.

Its an urgent issue any help is appreciated!

John VV 11-14-2012 03:27 PM

fedora 10 is 7 and almost 8 versions out of date
and has NOT seen a security update or fix in sense December 18 2009
3 years ago
ONLY fedora 16 and 17 are supported

is your ancient fedora 10 install a Xen set up

this is rather old software
i do not think it even supports ext3
reinstall USING a not dead OS using the older ext2 partition format

The OLD and on extended life support rhel4.9 -- not free
the just oldish RHEL 5.8 ( or free CentOS 5.8) would be a better choice of OS than the very long dead fedora 10

Shashaa 11-14-2012 03:40 PM

Thanks for the Reply John,

Yes I know its pretty old version of fedora, the reason I choose older version is; snowflock as you mentioned its an old package and there some dependencies while installing it and I thought choosing the latest version of fedora would cause more issues. However I don't think there is a problem with fedora;

The snowflock rpm will install a complete set of Xen userland tools, in addition to the hypervisor and domain 0 kernel, and it will change the /boot/grub/menu.lst.
it is as follows after installation:
<<<<<<<<<<<<< /boot/grub/menu.lst >>>>>>>>>>>>>>>>>>>>
title SnowFlock Xen 3.0.3 / Linux (
root (hd0,0)
kernel /xen-3.0.3-0.gz console=vga
module /vmlinuz- ro root=/dev/VolGroup00/LogVol00 rhgb quiet
module /initrd-
title Fedora (
root (hd0,0)
kernel /vmlinuz- ro root=UUID=aa42f034-8d19-43d4-8eb5-bbbdc3ff2b62 rhgb quiet
initrd /initrd-


John VV 11-14-2012 04:00 PM

try formating the drive to ext2 and reinstalling

ext3 is rather new
and using a still in support but just old CentOS 5.8 would be better than fedora

but it is YOUR install

Shashaa 11-14-2012 04:48 PM


I formatted the drive with ext2 and re installed the fedora, but due to some strange reasons I could still see the same error "mount: error mounting/dev/root on /sysroot as ext3: " though I have changed the file system to ext2. I guess the Xen 3.0.3 provided by the snowflock is by deafult searching for ext3, do you have any solution to this ?

yes I did tried on Centos before this, but there was some library dependency issues so could not install snowflock successfully.

Thanks for ur responses John, if you could lead me to a solution that would be great!!

John VV 11-15-2012 04:09 PM

at this point ...
contract Univ. of Toronto
it is their code

John VV 11-15-2012 04:14 PM

one more thing

did uou use a custome install of the old fedora 10 ?
if not, it then installed using LVM
Logical Volume Manager

back in fedora 10 it JUST stopped being the "beta testing" of it

if you did thin INSTALL using a CUSTOM instal
and Custom partition layout

Shashaa 11-16-2012 03:04 PM

Hi John,

Thanks for your time;

I came to know that, UofT released SnowFlock code is ancient, not maintained and probably not stable enough bolt an additional system on top. (It was a research prototype after all)(After leaving UofT, the authors of SnowFlock formed a startup based on the SnowFlock technology (

So I'm no longer intended to use snowflock for my experiments.


All times are GMT -5. The time now is 06:57 AM.