LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices


Reply
  Search this Thread
Old 08-20-2014, 12:05 PM   #1
insectiod
Member
 
Registered: Feb 2013
Posts: 34

Rep: Reputation: Disabled
qemu/kvm: permissions for pci-passthrough


Hi

I followed the instructions here to set up pci-passthrough for an audio card. I have unbound the pci device from the host and assigned it to the guest with the option
Code:
-device pci-assign,host=08:01.0
.
When I try to start this happens:
Code:
>>>qemu-system-x86_64 -m 1024 --enable-kvm -usb -vga qxl -spice port=6453,disable-ticketing -device pci-assign,host=08:01.0 win7audio.qcow2 
qemu-system-x86_64: -device pci-assign,host=08:01.0: Could not open '/sys/bus/pci/devices/0000:08:01.0/config': Permission denied
qemu-system-x86_64: -device pci-assign,host=08:01.0: Device initialization failed.
qemu-system-x86_64: -device pci-assign,host=08:01.0: Device 'kvm-pci-assign' could not be initialized
However when I run qemu with sudo it works. Is there a way to make this work without running as root.

versions:
slackware 14.1 64bit
qemu 2.1.0
 
Old 08-20-2014, 02:33 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 20,736

Rep: Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348Reputation: 3348
Simple answer should be yes. You need to find out what is set to not allow you to access some file(s) by permissions. I'd suspect /dev maybe but I'd think there would be some pages on what to change permissions on. Some distro's may allow you to be added to some group.
 
  


Reply

Tags
kvm, qemu, slackware 14.1


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Set up qemu-kvm-1.0+noroms as spice enabled qemu server vs qemu-kvm-spice on Ubuntu Precise LXer Syndicated Linux News 0 05-26-2012 07:41 AM
Chipset support for PCI Passthrough in KVM rajivdp Linux - Virtualization and Cloud 0 06-14-2011 02:02 AM
USB Passthrough Problem with KVM/QEMU on FC12 wdsnyc Linux - Virtualization and Cloud 1 02-23-2010 09:49 PM
PCI Passthrough with KVM fails martdj Linux - Virtualization and Cloud 5 02-01-2010 08:01 AM
problem with kvm and pci passthrough with two devices vegatux Linux - General 0 09-24-2009 10:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud

All times are GMT -5. The time now is 12:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration