-   Linux - Virtualization and Cloud (
-   -   Problem with fglrx drivers on Xen4.1 with debian kernel (

LeetShiva 09-29-2012 02:55 PM

Problem with fglrx drivers on Xen4.1 with debian kernel
I have problem with trying to run Xen4.1 Xen4.0 or Xen4.2 with the debian kernel
Actually problem isnt in running. Machine boots but when it starts gdm its screen dies and i need to use rescue combination ctrl+alt+sysRq+K to get to the console.
I have fglrx driver enabled as my xorg.conf driver and report this error(taken from /var/log/xorg.0.conf)

(EE) fglrx(0): V_BIOS address 0x0 out of range
(II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
(EE) fglrx(0): Invalid video BIOS signature!
(EE) fglrx(0): GetBIOSParameter failed
(EE) fglrx(0): PreInitAdapter failed
(EE) fglrx(0): PreInit failed
(II) fglrx(0): === [xdl_x750_atiddxPreInit] === end
(II) fglrx(0): Interrupt handler Shutdown.

I have tried with other drivers like radeon,radeonhd,vesa,ati but none want to load Xserver. All report simmilar message about V_BIOS problem.
On this machine I run AMD APU with AMD Radeon HD 6530D built in in APU.

Does anyone have idea what to try to make graphics work in Xen.

All times are GMT -5. The time now is 11:22 PM.