-   Linux - Virtualization and Cloud (
-   -   mounting pendrive on virtual machine (

Siddharth Sharma 02-20-2013 08:17 AM

mounting pendrive on virtual machine
i have installed RHEL5.4 server and i am not able to mount pendrive on virtual machine.

shivaa 02-20-2013 09:14 AM

Is your system able to recognize usb? Connect it to system and invoke:


~$ dmesg | grep -i 'usb'
~$ df -h

Also which VM you're using?

ukiuki 02-20-2013 09:14 AM

Welcome to LQ!

Have you tried in the guest virtual machine under menu Devices? You have to activate there first and then you can mount inside the guest system if it doesn't auto mount, but i think Fedora will auto mount it once you have it setup.


JockVSJock 02-20-2013 07:43 PM


Originally Posted by shivaa (Post 4895973)
Is your system able to recognize usb? Connect it to system and invoke:

Also which VM you're using?

Agreed....gonna need more info, also


$ lsusb

shivaa 02-20-2013 08:09 PM

I'd add more, before you share VM name & version. Sometimes some additional VM tools are required to get full functionality of all peripherals of host system. In case if you're using VMware, once have a look at this.

Have good luck!

Siddharth Sharma 02-21-2013 06:28 AM

i am using virtual machine manager 0.8.4
and have image as libvirt

Siddharth Sharma 02-21-2013 06:30 AM

and my system is recognizing the USB..

Siddharth Sharma 02-21-2013 06:33 AM

i have tried to access it as a storage device(IDE disk) and it almost work correctly but it is appearing as a separate hard-drive.
also tries to mount it but my m/c got crash..

shivaa 02-21-2013 09:11 AM

(Just a tip: You can use Edit option to put all your posts in one place).

Anyway, in case of machine crash, what does dmesg saying? and what about system logs? Did you see anything unusual?


~$ dmesg
~$ cat /var/log/messages

Also can you check following cmds?

~$ fdisk -l
~$ df -h

All times are GMT -5. The time now is 08:38 AM.