-   Linux - Virtualization and Cloud (
-   -   kvm offline migration (

sethusubbiah 07-28-2011 10:12 AM

kvm offline migration
I am using KVM in cents 5.6. I am trying to do offline migration between two machines. I have a common NFS server. I initially save the state of the running VM (on machine1) to a state file using :

/usr/libexec/qemu -m 1024 -hda image1.img (to start the vm) stop migrate "exec:gzip -c > state.gz"

It successfully saves the state. Now I can resume the vm on the same machine with :

/usr/libexec/qemu -m 1024 -hda image1.img -incoming "exec:gzip -c -d state.gz"

It works fine. But is I use the same command in machine 2, I get :

gzip: stdout: Broken pipe.

Either the vm doesn't give any output or it starts from scratch and not from the memory state. I dont know the mistake I am committing. It will be great if someone can give me some pointers, tips or help on this issue. Thanks a lot.

- Sethu

sethusubbiah 07-29-2011 12:24 PM

[Solved] It is a dumb issue which I didn't think of. Even though both machines are running the same OS with same kernel, the qemu version on machine 1 was 0.10.5 and the other machine was 0.12.4 . I downgraded the second machine's qemu version to 0.9.1 and it works now.

All times are GMT -5. The time now is 04:46 AM.