-   Linux - Virtualization and Cloud (
-   -   KVM Guest Install Error - Could not find an installable distribution (

linbox289 02-16-2011 04:00 AM

KVM Guest Install Error - Could not find an installable distribution
I tried installing Virtual machine using KVM as per the instructions while creating guest

ubox@ubox:~$ sudo virt-install --connect qemu:///system --name vmbox1 --ram 512 --file=/VM/1/disk1.img --file-size=8 --network=bridge:br0 --vnc --os-type=linux --os-variant=ubuntulucid --location=/tmp/ubuntu-10.04.1-server-amd64_2.iso

Starting install...
ERROR Could not find an installable distribution at '/tmp/ubuntu-10.04.1-server-amd64_2.iso'
Domain installation does not appear to have been successful. If it was, you can restart your domain by running 'virsh start vmbox1'; otherwise, please restart your installation.
ERROR Could not find an installable distribution at '/tmp/ubuntu-10.04.1-server-amd64_2.iso'
Traceback (most recent call last):
File "/usr/bin/virt-install", line 1033, in <module> main()
File "/usr/bin/virt-install", line 915, in main start_time, guest.start_install)
File "/usr/bin/virt-install", line 957, in do_install dom = install_func(conscb, progresscb, wait=(not wait))
File "/usr/lib/pymodules/python2.6/virtinst/", line 971, in start_install self._prepare_install(meter)
File "/usr/lib/pymodules/python2.6/virtinst/", line 772, in _prepare_install meter = meter)
File "/usr/lib/pymodules/python2.6/virtinst/", line 249, in prepare self._prepare_kernel_and_initrd(guest, distro, meter)
File "/usr/lib/pymodules/python2.6/virtinst/", line 194, in _prepare_kernel_and_initrd type=self.os_type, distro=distro)
File "/usr/lib/pymodules/python2.6/virtinst/", line 144, in acquireKernel scratchdir, type, distro)
File "/usr/lib/pymodules/python2.6/virtinst/", line 124, in _acquireMedia scratchdir=scratchdir, arch=arch)
File "/usr/lib/pymodules/python2.6/virtinst/", line 110, in _storeForDistro baseuri)
ValueError: Could not find an installable distribution at '/tmp/ubuntu-10.04.1-server-amd64_2.iso'

I have placed the ISO image under /tmp I am not sure whether I messed up with something, please guide.

Ubuntu version : Ubuntu Desktop Edition 10.04 LTS


dyasny 02-17-2011 09:51 AM

does it work if you `sudo chmod 777 /tmp/ubuntu-10.04.1-server-amd64_2.iso` ?

---------- Post added 02-17-11 at 02:52 PM ----------

oh, and btw, does your system have VT/SVM? is kvm loaded? is the host OS x86_64?

linbox289 02-18-2011 01:34 AM

does it work if you `sudo chmod 777 /tmp/ubuntu-10.04.1-server-amd64_2.iso` ? - I tried changing the permission but it didn't help me.

does your system have VT/SVM? - yes it does
is kvm loaded? - yes
is the host OS x86_64? - yes

Later I moved the iso file to /cdrom and it worked fine. But then too, am still not sure why it cant fetch the file from /tmp :(

things worked fine, and I have installed the new VM. 2 more problems

1. I cant ping/ssh the VM guest machine from other network computers, while I need to ssh the host machine then from host I am able to connect the guest thro' ssh. Could not figure out what the prob.

2. I need to know how I can use virt-manager from other machine in-order to manage the vm guests. (case: host runs ubuntu server)

dyasny 02-18-2011 07:11 AM

1. you need to build a bridge on top of your NIC and assign the bridge the IP and MAC of the NIC, leave the NIC itself with no configs besides starting automatically on boot. Then attach the VMs to the bridge, make their network config "bridged" using that bridge.
This will place the VMs and the host in the same network, the bridge acting as the eth for the host as well as a virtual hub for the VMs.

2. ssh -X to the host, and start virt-manager is what I prefer to do. but you can also install virt-manager on your own machine, and connect remotely. Problem with this is, if you have different versions of virt-manager between your machine and the VM host, you might find yourself in weird places

All times are GMT -5. The time now is 08:54 PM.