LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   guest additions error when compiling - kernel configuration is invalid (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/guest-additions-error-when-compiling-kernel-configuration-is-invalid-4175676158/)

sirius57 05-29-2020 02:53 PM

guest additions error when compiling - kernel configuration is invalid
 
I am unable to install guest additions for debian linux. I installed kernel header to match kernel version and guest additions complains it can not find the headers for the kernel version.

error: kernel configuration is invalid.
Include/generated/autoconfig.h or include/config/auto.conf are missing.
Run 'make oldconfig && make prepare' on kernel src to fix it.'

Will running the make command install the missing files if the kernel source code is installed in the system?

smallpond 05-29-2020 03:09 PM

You need both the correct kernel source and the correct kernel config file copied to the kernel source directory .config. Then run the listed make commands.

sirius57 05-31-2020 08:41 PM

I have the kernel source and kernel config files in the .config folder. I get 'no rule to make target oldconfig'. I searched for example syntax and am not sure what 'make' wants on the command line for output.

smallpond 06-01-2020 09:30 AM

.config should be a file, not a folder.

sirius57 06-01-2020 10:03 PM

I had to search for .config file and was able to run make oldconfig and make prepare. Both ran with no errors as I could see the progress in the terminal window. However, I was stymied with compiling the guest additions. In synaptic package manager is listed kernel source 4.19 and the kernel source meta package that depends on the kernel source packages. I have both installed.

sirius57 06-12-2020 08:20 PM

solved problem
 
I found that the guest additions from within virtualbox 4.2.18 was the problem. I tried several iso files from virtualbox index repository. The later guest additions versions will compile without error. The latest guest additions iso enabled auto resize guest display option in the guest, but froze the guest as well. An earlier iso version 5.2.42 will also compile but the resize guest display option is grayed out. However, I can share folders. The guest is Debian 10.


All times are GMT -5. The time now is 04:22 PM.