LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   Get sent to EFI shell when booting from Windows ISO (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/get-sent-to-efi-shell-when-booting-from-windows-iso-4175657796/)

resuni 07-21-2019 10:12 AM

Get sent to EFI shell when booting from Windows ISO
 
I'm following the guide on Arch wiki to get PCI passthrough set up. (My host OS is actually openSUSE).

I'm at the point where I'm trying to install Windows, but I cannot get the ISO to boot and I keep getting sent to the EFI shell. I've tried using two Windows 7 ISOs and a Windows 10 ISO.

With Windows 7, when I get sent to the EFI shell, I've tried the following:
  • Type exit, then select "continue" in the BIOS-looking interface. This brings me back to the EFI shell.
  • Type exit, then select to boot from DVD from the BIOS. This also brings me back to the EFI shell.
  • In the EFI shell, run EFI\BOOT\BOOTX64.EFI. This gives me an error: Command Error Status: Security Violation

This Windows 7 ISO was made from a DVD I bought years ago, so I thought maybe I should try a new one. I downloaded a new one from the Microsoft site, but I get the same results.

With Windows 10, I get slightly different behavior. It prompts me to press any key to boot from DVD, so I do. This sends me to the EFI shell. I try the same three things I listed for Windows 7 above, it asks me to press any key, then sends me to the EFI shell regardless if I press a key or not.

I don't know what to try next. My immediate thought is maybe I'm using a bad OVMF image. When I build the VM, I select "UEFI x86_64: /usr/share/qemu/ovmf-x86_64_ms-code.bin". I'm using openSUSE Tumbleweed and I assume this file came from the "ovmf" package I installed. Maybe I somehow need to be choosing a different OVMF image?

colorpurple21859 07-22-2019 05:37 AM

Quote:

Gotchas
Using a non-EFI image on an OVMF-based VM

The OVMF firmware does not support booting off non-EFI mediums. If the installation process drops you in a UEFI shell right after booting, you may have an invalid EFI boot media. Try using an alternate linux/windows image to determine if you have an invalid media.
I don't about the windows 10, but your windows 7 most likely is non-efi.

resuni 07-22-2019 09:41 AM

That's why I tried downloading a new Windows 7 ISO from Microsoft. And if that were the case, why would Windows 7 have the same EFI\BOOT\BOOTX64.EFI file that also exists on the Windows 10 ISO?

colorpurple21859 07-22-2019 09:53 AM

Quote:

This Windows 7 ISO was made from a DVD I bought years ago
This is the one I was referring to.
Why the windows 10 and the new windows 7 iso, I don't know, unless the iso only works after being burned to dvd/cd

resuni 07-23-2019 09:50 PM

I downloaded a new Windows 10 ISO from Microsoft, and that one worked.

Solved.


All times are GMT -5. The time now is 09:10 PM.