-   Linux - Virtualization and Cloud (
-   -   Converting VMWare image using LVM to KVM (

kheldar 03-21-2011 06:01 AM

Converting VMWare image using LVM to KVM
Hi! I've foolishly tried to reopen a solved thread, so I'll post again to a new thread. Sorry!

I've followed instructions to convert a VMWare image vmdk into a qcow2 image, which opens fine, but seconds into the boot I get the message.

volume group "volgroup00" not found
unable to access resume device /dev/volgroup00/logvol01

The existing image is a CENTOS 5.5 x86_64 server, and the VMWare host is the same running on an AMD cpu. I'm trying open the converted host on a Fedora 14 X86_64 server, using an intel CPU.

Interestingly, if I use the rescue facility on the Fedora 14 DVD, it mounts the rescued system correctly complete with the lvm partitions, so there can't be anythign physically wrong with the migrated data.

Any suggestions would be appreciated.

kbp 03-21-2011 04:46 PM

I think this might help


kheldar 03-23-2011 06:15 PM

It did, thanks, although indirectly.

It turned out that the issue was that the guest (CentOS5) doesn't support VirtIO drives, or at least not with LVM running on them.

I dropped the VirtIO drive and replaced it with exactly the same image as a IDE drive and it worked.

Full details here.

All times are GMT -5. The time now is 06:56 AM.