-   Linux - Virtualization and Cloud (
-   -   Centos 6.3 on Hyper-V - Installed LIS 3.4 and lost NIC Communication (

gcaudle 11-27-2012 07:58 AM

Centos 6.3 on Hyper-V - Installed LIS 3.4 and lost NIC Communication
I recently installed LIS 3.4 on a VM in Hyper-V running Centos 6.3. This machine had been running for some time with the legacy network adapter. I only recently learned of the LIS peice to fix this. So after reading the docs, I installed it per the document provided with LIS 3.4. Thats where it went lal wrong. I lost my cdrom and my NIC. I was able to get the CDROM back, but the NIC remained lost. I learned form the output of dmesg that it had been renamed to eth6. So, I named my ifcfg script apporpriately and restarted my network services, and the machine even. The NIC appears to come up, but it cannot ping anything or be pinged. Iptables is down, my gateway is loaded in /etc/sysconfig/network-scripts-network and it appears if I run a "route" command. I have tried removing the legacy network adaptoer, adding regular NIC, and vice versa and its always the same result. I have also rebuilt my ifcfg script for DHCP instead of static and it failes to receive a dhcp address everytime. I also tried removing LIS per the doc and it fails to remove the microsoft-hyper-v-rhel63-3.4-1.20120727 saying ... error reading information on service hv_kvp_daemon: No such file or directory. I cannot foind any info on that to try and resolve. I am completely lost at this point.

Centos 6.3 Final
kernel 2.6.32-279
Hyper-v running on Windows 2008 Enterprise

gcaudle 11-30-2012 02:54 PM

I finally got it fixed. The Virtual Network setup in Virtual Network Manager in the Hypervisor had become corrupted. I deleted it, built a new one, deleted the synthetic nic and wnet back to legacy nic. Started the VM and it came up. Granted, its slower performance, but now i can get the data out of it and move it to a VMWare box or a physical server where it belongs rather than a Microsoft product.

All times are GMT -5. The time now is 09:50 PM.