-   Linux - Virtualization and Cloud (
-   -   cannot get virtualbox with windows xp to recognize usb ports (

BirdyMan 02-12-2010 01:53 PM

cannot get virtualbox with windows xp to recognize usb ports
well i have an xbox 360 hard drive transfer kit because i like to try to modify games and stuff, and what i did on xp was i plugged it in to my hard drive, but computers dont recognize it. so you have to use a program called xport 360, it recognizes it and opens it. anyways, now i have a linux computer and instead of using wine, i like to use virtualbox. well xport 360 only works on windows, so i have to use it on vbox. the problem is that i dont know how to get windows xp (on vbox) to recognize usb ports or devices. i even tried a flash drive, but it still wont work. how can i get it to recognize usb devices?

brianL 02-12-2010 02:02 PM

There's two versions of VirtualBox, the OSE and the PUEL, check which one you have. Only the PUEL supports USB.

BirdyMan 02-13-2010 07:52 AM

thanks for the help, but i have another question for you. i installed PUEL, but whenever i try to run a virtual machine, it gives me this message:

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Re-setup the kernel module by executing


'/etc/init.d/vboxdrv setup'
as root. Users of Ubuntu or Fedora should install the DKMS package at first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

ive setup the kernel module a million times, but nothing has happened. i also tried to add myself to the vboxusers group again, but it says im still in it. could you please help me?

adam999 02-13-2010 07:56 AM

add your user to the vboxusers and usb groups.

brianL 02-13-2010 10:23 AM

Since Mint is based on Ubuntu, have you installed the DKMS package?

damgar 02-13-2010 10:39 AM

Also, for my Iphone to be recongnized I have to set up a USB filter for the Iphone. It then works perfectly.

BirdyMan 02-14-2010 07:56 PM

answers for all three of you

adam999: i already have, it still doesnt change it.

brianL: yes, i already have it, but it still wont do anything.

damgar: i just tried making a filter and it works, thanks!

Thank you all, you all helped a lot.

damgar 02-14-2010 10:16 PM

Happy to help.

All times are GMT -5. The time now is 02:24 PM.