-   Linux - Virtualization and Cloud (
-   -   Cannot connect to newly created vm's using virt-viewer (

DraughtGlobe 03-03-2011 04:44 PM

Cannot connect to newly created vm's using virt-viewer
Hello there!

I've successfully created 2 virtual machines on my server using virt-install. I can see them listed using virsh but I can't connect to them using virt-viewer.. virt-viewer doesn't give me any helpful info besides the following:

vm-admin@ubuntu:~$ virt-viewer --connect qemu:///system vm1
Cannot open display:
Run 'virt-viewer --help' to see a full list of available command line options
vm-admin@ubuntu:~$ virsh -c qemu:///system list
 Id Name                State
 16 vm1                  running
 17 vm2                  running


My first vm was kind of an exotic os (called mineos). When I got this error, I tried it using a second vm running debian. However, i can't connect to it aswell. It leaves me with the same error message.

I used the following command to create my debian vm. I used a smilar command for my first vm

vm-admin@ubuntu:~$ virt-install --connect qemu:///system -n vm2 -r 512 --vcpus=2 -f /home/vm-admin/vms/vm2.qcow2 -s 1 -c /home/vm-admin/debian-6.0.0-amd64-netinst.iso --vnc --noautoconsole --os-type linux --accelerate --network=bridge:br0 --hvm
Being root doesn't help either. I'm currently running ubuntu 10.10 server edition (headless).

I'm relatively new to all this vm stuff so I was wondering if one of you guys might have a solution, or an direction where to look. :)

Thanks in advance!

dyasny 03-04-2011 07:16 AM

you can try qemu+ssh:// or just use a VNC client

DraughtGlobe 03-08-2011 03:02 PM

I thought I had read somewhere that virt-viewer doesn't need a gui:P
Apparently it does, got it working now :) (The Cannot open display error makes a lot more sense now actually....)


All times are GMT -5. The time now is 12:50 AM.