LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   After cloning VM in vSphere, network.service fails to start (https://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/after-cloning-vm-in-vsphere-network-service-fails-to-start-4175654330/)

Latitude 05-21-2019 12:26 PM

After cloning VM in vSphere, network.service fails to start
 
Hi LQ community! After I cloned a production RHEL 7.6 server in VMware vSphere 6.5 to a sandbox, the network.service fails to start.

I'm using VMware vSphere Client version 6.5.0.23000 to clone a RHEL VM. I've tried manually starting the networking service after it fails to come up during boot and receive the prompt: 'See "systemctl status network.service" and "journalctl -xe" for details.'

journalctl -xe shows:

network.service: control process exited, code=exited status=1
Failed to start LSB: Bring up/down networking.
Unit network.service has failed.

Unit network.service has begun starting up.
bringing up loopback interface: [ OK ]
Bringing up interface eth0: RTNETLINK answers: File exists
[ OK ]
Bringing up interface p1p1: ERROR : [/etc/sysconfig/network-scripts/ifup-eth] Device p1p1 does not seem to be present, delaying initialization.

I've been Google searching for quite a while on this and saw a lot of similar *but* different instances of this error, so I tried adding the MAC address to the ifcfg-eth0 file and restarted the network. Still failed. Ideas / tips are appreciated.

tyler2016 05-21-2019 02:54 PM

My guess is udev has a persistence rule for the NICs, and since your NICs are now "different", they have different names. Try this:

Code:

cd /etc/sysconfig/network-scripts
ip link list
ls

If the interfaces shown by IP differ from the files in network-scripts, rename them to match. Make sure you edit them. You will probably have to comment out or update UUID as well as the NAME and DEV lines. I don't have an RHEL box available at the moment to check, but NAME and DEV might be a little different.

HTop 05-22-2019 07:18 AM

This is due to MAC address of the nic.
As the MAC Address is changing on your clone, on clone you should edit the /etc/sysconfig/network-scripts/ifcfg-ensXXX and remove the MAC address of that correspond to the original VM. You do not need to add the new one.


All times are GMT -5. The time now is 02:42 PM.