LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-27-2004, 03:26 PM   #1
nyk
Member
 
Registered: Jan 2004
Location: Berne, Switzerland
Distribution: FC4, Gentoo
Posts: 112

Rep: Reputation: 15
zombie


top report 1 zombie process... how do I find out which one it is?
 
Old 10-27-2004, 03:39 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
You can use:
ps -ef | grep defunct
 
Old 10-27-2004, 04:19 PM   #3
nyk
Member
 
Registered: Jan 2004
Location: Berne, Switzerland
Distribution: FC4, Gentoo
Posts: 112

Original Poster
Rep: Reputation: 15
thanks!

I got a
nyk 2924 2881 0 22:23 ? 00:00:00 [netstat] <defunct>

and can't kill it even as root with kill -9

what's the matter with it?

this problems all appeared since I installed an extra 512MB DDR RAM and a new SB soundcard today.

and mlnet doesn't work anymore since that too. it runs, but I can't connect to the telnet/www interfaces!

very strange... what could this be?
 
Old 10-27-2004, 04:49 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
it looks like that proccess isn't the parent - try killing the parent proccess off first.
 
Old 10-27-2004, 04:57 PM   #5
nyk
Member
 
Registered: Jan 2004
Location: Berne, Switzerland
Distribution: FC4, Gentoo
Posts: 112

Original Poster
Rep: Reputation: 15
I tought zombies don't have no parent anymore..?

and I mean what could be the REASON? I never had a zombie before!!
 
Old 10-27-2004, 08:29 PM   #6
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
If kill -9 doesn't work for me...try pkill -9 <pid>

-twantrd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Zombie Process N|k0N Linux - Security 8 09-22-2007 02:01 AM
zombie process ihatecomputers Linux - Software 2 03-24-2005 07:09 AM
xscreensaver goes zombie? jpbarto Linux - Software 1 08-11-2003 03:55 PM
Zombie Process Handling kghoshal Linux - Newbie 2 07-21-2003 09:10 AM
zombie processes mhr Linux - Newbie 1 06-19-2003 09:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration