LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   z-mac installation on ns2.34 (https://www.linuxquestions.org/questions/linux-software-2/z-mac-installation-on-ns2-34-a-944856/)

arica 05-15-2012 08:57 AM

1. gcc41-compat set....both ...using....sudo dpkg -i gcc41-compat-4.1.2_i386.deb g++41-compat-4.1.2_i386.deb
.. Then reboot, and the new compilers can be used.

2. patching done!! using patch -p0 < ns-2.26-gcc410.patch

3. root@priyanka-Aspire-5745:/usr/local/ns-allinone-2.26#export CC=gcc41 CXX=g++41 && ./install......
and again error..

checking for Solaris2.4/Tru64 strtod bugs... ok
checking for ANSI C header files... yes
checking for mode_t... yes
checking for pid_t... yes
checking for size_t... yes
checking for uid_t in sys/types.h... yes
checking for opendir... (cached) yes
checking union wait... yes
checking matherr support... yes
checking for strncasecmp... yes
checking for BSDgettimeofday... no
checking for gettimeofday... yes
checking for gettimeofday declaration... present
checking whether char is unsigned... no
checking signed char declarations... yes
checking for sin... no
checking for main in -lieee... yes
checking for main in -linet... no
checking for net/errno.h... no
checking for connect... yes
checking for gethostbyname... yes
checking if 64bit support is requested... no
checking if 64bit Sparc VIS support is requested... no
checking system version (for dynamic loading)... ./configure: 1: Syntax error: Unterminated quoted string
tcl8.3.2 configuration failed! Exiting ...
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform.



tcl failed..y??help

knudfl 05-15-2012 09:29 AM

Quote:

./configure: 1: Syntax error: Unterminated quoted string
That's an error which will appear, when no 'ns-2.26-gcc410.patch' is used.

The patch should be applied in /usr/local/ ,
i.e. outside the "ns-allinone-2.26/" folder.


.

arica 05-15-2012 10:14 AM

thanks @knudfl........ns2.26 installed on ubuntu 10.10..... :-).....now trying Drand and z-mac installlation....lets see...thanks again...

arica 05-15-2012 11:11 AM

now while installing DRAND and Z-MAC...from..

1.http://www4.ncsu.edu/~rhee/export/zm.../zmac/zmac.htm
and
2.http://www4.ncsu.edu/~rhee/export/zm...rand/drand.htm


follwing the instructions on this page....

from 1. ns2 installation instructions done...
from 2. ns2 installation instructions done..and while executing the simulation for ns2 execution instructions on 2. i.e simulating simple-wireless.tcl as...
root@priyanka-Aspire-5745:/usr/local/ns-allinone-2.26/ns-2.26/drandTcl# ns simple-wireless.tcl 6 new-scen-6-60-60
num_nodes is set 6
INITIALIZE THE LIST xListHead
invalid command name "Agent/DRAND"
while executing
"Agent/DRAND create _o111 "
invoked from within
"catch "$className create $o $args" msg"
invoked from within
"if [catch "$className create $o $args" msg] {
if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
delete $o
return ""
}
global errorInfo
error "class $..."
(procedure "new" line 3)
invoked from within
"new Agent/DRAND"
("for" body line 2)
invoked from within
"for { set i 0} { $i < $numNodes } { incr i} {
set drand($i) [new Agent/DRAND]
$drand($i) set randomSeed_ [ns-random]
$ns_ attach-agent $no..."
(file "simple-wireless.tcl" line 38)
.....got again the same error..as for ns2.34......help me sort out this....

arica 05-15-2012 11:14 AM

also tell me before running tcl script simple-wireless.tcl....i have to agin make ns2.26 or insatll ns??????or just run the script...


error..agin goes to #1...........no use working whole day...

arica 05-15-2012 11:16 AM

what is scenario.tcl file in $ns simple-wireless.tcl <numnodes> <scenario.tcl>
....is it the file created from ./setdest i.e new-scen-N-X-Y..???
help needed!!

knudfl 05-15-2012 11:20 AM

# 34
Quote:

ns simple-wireless.tcl
Sorry, not possible with the "ns-drand" binary, to run an "ns 2.26 simple-wireless.tcl"
To run default files : Set up a third version of ns-allinone-2.26,
and copy the binary ns to ns226.
'ns226 simple-wireless.tcl' should then work.

Be aware that you also need separate ns-allinone-2.26 installs
for DRAND and ZMAC. ( A zmac ns-2.26 cannot run DRAND stuff. AFAIK.)

.

arica 05-15-2012 11:32 AM

Sorry, not possible with the "ns-drand" binary

...what is ns-drand binary???

To run default files : Set up a third version of ns-allinone-2.26,
and copy the binary ns to ns226.
.....how to create the third version.???...i dnt know even to craete 1st nd 2nd versions...how???

meanwhile....ns with the drand instructions followed...instlled correctlyyyy...and i have also saved the previous version of ns without instructions....that was also installed correctly...

then y this error showing???

arica 05-15-2012 11:34 AM

y this tcl script is not running???

knudfl 05-15-2012 11:38 AM

# 36
Quote:

What is scenario.tcl file in $ns simple-wireless.tcl <numnodes> <scenario.tcl>
First : I'd guess, that the special simple-wireless.tcl from drandTcl.tar.gz
is to be used. (It is not ns-2.26/tcl/ex/simple-wireless.tcl ).
http://www4.ncsu.edu/~rhee/export/zm...randTcl.tar.gz

"scenario.tcl" : I don't know. Just try out, what you have.
(There is a "wirelessOpt.tcl" in drandTcl.tar.gz ).

knudfl 05-15-2012 11:45 AM

... And please spell out your words. Write why, not y when you mean 'why',
etc etc. Short hand writing / SMS language is not accepted here at LQ.

Please edit your posts to be readable. Please edit spell errors.

arica 05-15-2012 12:53 PM

yess....your guess is right..it is from the drandTCL.tar.gz....
..
..

i m getting the error post #34.....

arica 05-15-2012 01:08 PM

..the same error with some other file is there...i searched it....

http://my.opera.com/HenryFD/blog/show.dml/192233

...they told to make..them make install...........and others as....make clean then make depend then make and then make install....
also suggested to add variables...
..
in..ns2.26/tcl/lib...with reference to .cc files..i.e drandAgent.cc in our case....
how this is done???

Thanks for checking above and help me out also...
Thanks again!!

arica 05-15-2012 01:10 PM

also consider my post #38

arica 05-15-2012 02:17 PM

nothing working again.....i dnt know whats the problem....same error post #1..spend my whole day on it...


All times are GMT -5. The time now is 08:04 PM.