LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-16-2008, 08:44 AM   #1
daveginorge
Member
 
Registered: Oct 2006
Location: Porsgrunn, Norway
Distribution: CentOS 5 / 6 / 7
Posts: 107

Rep: Reputation: 16
Yum update fails due to file conflict


I was doing a yum -y update to a remote server using vnc as I always do and for some reason I lost connection with 'connection was reset by host' I was half way through a 60 package update session.

Now if I run yum -y update I get 28 packages to be updated. During the transaction check I get 28 errors.... file "/this file ver .fc8.i386" from install conflicts with "/this file ver .fc8.x86_64"

I am running x86_64 OS so it looks like yum has downloaded and tried to install i386 system files. I have tried "yum clean all" and then "yum -y update" only to get the same issue

What do I do now to correct this issue.

Thanks in advance.

Here is some of the yum output.

[root@dilon ~]# yum -y update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-keyring.i386 0:2.20.3-1.fc8 set to be updated
---> Package gnome-system-monitor.x86_64 0:2.20.2-1.fc8 set to be updated
---> Package yelp.x86_64 0:2.20.0-7.fc8 set to be updated
---> Package openldap.i386 0:2.3.39-3.fc8 set to be updated
---> Package xorg-x11-drv-nouveau.x86_64 0:2.1.6-1.fc8 set to be updated
---> Package krb5-libs.i386 0:1.6.2-11.fc8 set to be updated



--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
control-center x86_64 1:2.20.3-2.fc8 updates 2.9 M
control-center i386 1:2.20.3-2.fc8 updates 2.9 M
e2fsprogs-libs i386 1.40.4-1.fc8 updates 138 k
ekiga x86_64 2.0.11-2.fc8 updates 6.6 M
evolution-data-server x86_64 1.12.3-2.fc8 updates 3.7 M
evolution-data-server i386 1.12.3-2.fc8 updates 3.7 M
firefox i386 2.0.0.12-1.fc8 updates 21 M


Transaction Summary
=============================================================================
Install 0 Package(s)
Update 35 Package(s)
Remove 0 Package(s)

Total download size: 106 M
Downloading Packages:
(1/35): ekiga-2.0.11-2.fc 100% |=========================| 6.6 MB 00:04
(2/35): gnome-panel-2.20. 100% |=========================| 3.5 MB 00:02
(3/35): control-center-2. 100% |=========================| 2.9 MB 00:01
(4/35): evolution-data-se 100% |=========================| 3.7 MB 00:02
(5/35): gnome-session-2.2 100% |=========================| 505 kB 00:00
(6/35): gucharmap-1.10.2- 100% |=========================| 2.6 MB 00:01
(7/35): gnome-keyring-pam 100% |=========================| 21 kB 00:00
(8/35): gstreamer-plugins 100% |=========================| 879 kB 00:00
(9/35): libwnck-2.20.3-1. 100% |=========================| 323 kB 00:00
(10/35): e2fsprogs-libs-1 100% |=========================| 138 kB 00:00
(11/35): gnome-panel-2.20 100% |=========================| 3.4 MB 00:02
(12/35): evolution-data-s 100% |=========================| 3.7 MB 00:02
(13/35): control-center-2 100% |=========================| 2.9 MB 00:02
(14/35): libbonobo-2.20.3 100% |=========================| 469 kB 00:00
(15/35): libwnck-2.20.3-1 100% |=========================| 322 kB 00:00
(16/35): mesa-libGL-7.0.2 100% |=========================| 11 MB 00:06
(17/35): orca-2.20.3-1.fc 100% |=========================| 1.6 MB 00:01
(18/35): glib2-2.14.6-1.f 100% |=========================| 849 kB 00:00
(19/35): gnome-desktop-2. 100% |=========================| 952 kB 00:00
(20/35): gnome-menus-2.20 100% |=========================| 202 kB 00:00
(21/35): rhythmbox-0.11.3 100% |=========================| 5.0 MB 00:03
(22/35): libgtop2-2.20.1- 100% |=========================| 115 kB 00:00
(23/35): firefox-2.0.0.12 100% |=========================| 21 MB 00:12

Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/share/locale/et/LC_MESSAGES/gnome-keyring.mo from install of gnome-keyring-2.20.3-1.fc8.i386 conflicts with file from package gnome-keyring-2.20.2-1.fc8.x86_64
file /usr/share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo from install of gnome-keyring-2.20.3-1.fc8.i386 conflicts with file from package gnome-keyring-2.20.2-1.fc8.x86_64
file /etc/gconf/schemas/metacity.schemas from install of metacity-2.20.2-1.fc8.i386 conflicts with file from package metacity-2.20.1-1.fc8.x86_64
file /usr/share/locale/es/LC_MESSAGES/metacity.mo from install of metacity-2.20.2-1.fc8.i386 conflicts with file from package metacity-2.20.1-1.fc8.x86_64
file /usr/share/locale/fr/LC_MESSAGES/metacity.mo from install of metacity-2.20.2-1.fc8.i386 conflicts with file from package metacity-2.20.1-1.fc8.x86_64
file /usr/share/locale/pt_BR/LC_MESSAGES/metacity.mo from install of metacity-2.20.2-1.fc8.i386 conflicts with file from package metacity-2.20.1-1.fc8.x86_64
file /usr/share/locale/sk/LC_MESSAGES/metacity.mo from install of metacity-2.20.2-1.fc8.i386 conflicts with file from package metacity-2.20.1-1.fc8.x86_64
file /usr/share/desktop-directories/Accessibility.directory from install of gnome-menus-2.20.3-1.fc8.i386 conflicts with file from package gnome-menus-2.20.2-1.fc8.x86_64
file /usr/share/desktop-directories/Accessories.directory from install of gnome-menus-2.20.3-1.fc8.i386 conflicts with file from package gnome-menus-2.20.2-1.fc8.x86_64
file /usr/share/desktop-directories/Applications.directory from install of gnome-menus-2.20.3-1.fc8.i386 conflicts with file from package gnome-menus-2.20.2-1.fc8.x86_64
file /usr/share/desktop-directories/Development.directory from install of gnome-menus-2.20.3-1.fc8.i386 conflicts with file from package gnome-menus-2.20.2-1.fc8.x86_64


Error Summary
-------------

Last edited by daveginorge; 02-16-2008 at 09:05 AM.
 
Old 02-17-2008, 09:09 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Try the following;

rpm -e gnome-menus-2.20.2-1.fc8.i386 metacity-2.20.2-1.fc8.i386 gnome-keyring-2.20.2-1.fc8.i386 --test

If you get no errors then remove the test switch at the edn and really remove the three 32-bit packages. If you do get dependencies errors then carefully add them to the command above until the dependency issues re resolved.

This issue is fairly common with 64-bit installations, a lot of extra 32-bit packages are installed by default when they are not truly needed. Some are depending on what 32-bit packages are installed and used, this conflict issue gives you the opportunity to start removing undesired/unwanted/unnecessary 32-bit packages. But be very care when doing this as to not break your system, notice the packages to be removed are exactly named right down to the arch version.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Update YUM Fails sajdutt Linux - Software 7 03-09-2009 11:37 PM
Yum repository (dries) unable to update due to disk crash O(V)eGA_l2el) Fedora 6 11-09-2007 07:28 AM
xfs fails after yum update davidwiener Fedora 0 11-22-2006 10:47 AM
yum update dbus results in file conflict dvlierop Fedora 2 11-13-2005 04:21 AM
fc3:yum won't update - selinux conflict logo Linux - Software 2 09-18-2005 04:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration