LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Yum update (https://www.linuxquestions.org/questions/linux-software-2/yum-update-4175582571/)

cellranking 06-18-2016 09:42 AM

Yum update
 
hello
Room I did yum update try to patch the redhat box this message I got please help

[root@XXX]$yum update

---> Running transaction check
---> Package compat-xcb-util.x86_64 0:0.4.0-2.2.el6 will be installed
---> Package libepoxy.x86_64 0:1.2-3.el6 will be installed
---> Package libevdev.x86_64 0:1.4.5-2.el6 will be installed
---> Package libnl3.x86_64 0:3.2.21-8.el6 will be installed
---> Package libsmbios.x86_64 0:2.2.27-4.12.1.el6 will be updated
--> Processing Dependency: libsmbios = 2.2.27-4.12.1.el6 for package: python-smbios-2.2.27-4.12.1.el6.x86_64
---> Package libxshmfence.x86_64 0:1.2-1.el6 will be installed
---> Package mesa-libxatracker.x86_64 0:11.0.7-4.el6 will be installed
---> Package xcb-util-renderutil.x86_64 0:0.3.9-3.el6 will be installed
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-573.18.1.el6 will be erased
---> Package kernel-devel.x86_64 0:2.6.32-573.18.1.el6 will be erased
---> Package libsmbios.x86_64 0:2.2.27-4.12.1.el6 will be updated
--> Processing Dependency: libsmbios = 2.2.27-4.12.1.el6 for package: python-smbios-2.2.27-4.12.1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: python-smbios-2.2.27-4.12.1.el6.x86_64 (@dell-omsa-indep)
Requires: libsmbios = 2.2.27-4.12.1.el6
Removing: libsmbios-2.2.27-4.12.1.el6.x86_64 (@dell-omsa-indep)
libsmbios = 2.2.27-4.12.1.el6
Updated By: libsmbios-2.2.27-1908.9058.el6.x86_64 (dell-omsa-indep)
libsmbios = 2.2.27-1908.9058.el6
Available: libsmbios-2.2.26-3.el6.i686 (epel)
libsmbios = 2.2.26-3.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

John VV 06-18-2016 12:28 PM

i am guessing you have not read the cent wiki on third party repos
and did not install and configure "yum-priorites" plugin

https://wiki.centos.org/AdditionalRe...s/Repositories

the plugin
https://wiki.centos.org/PackageManag...Yum/Priorities
you have to configure this !!!

your issue is caused by conflicting packages from incompatible repos


also did you try the SOLUTION posted in that error ?
and use "skip broken"


All times are GMT -5. The time now is 06:43 AM.