LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-28-2013, 11:28 AM   #1
oly_r
Member
 
Registered: Dec 2011
Posts: 31

Rep: Reputation: Disabled
yum repo issue with iso disk1 and disk2


I have the Centos 6.3 iso's mounted as a loop to 64bitCentOS/disk1 and 64bitCentOS/disk2. the disk 2 iso hasn't been mounted in the past. The yum repo for base

Code:
[base]
name=CentOS-$releasever - Base
baseurl=http://YumSvr/64bitCentOS/disk1
gpgcheck=1
gpgkey=file:///yada/yada/yada/RPM-GPG-KEY-CentOS-6
I've tried a few settings in the repo file including one that seemed to actually work even though it showed an error. That setup is
Code:
[base]
name=CentOS-$releasever - Base
baseurl=http://YumSvr/64bitCentOS/disk1
baseurl=http://YumSvr/64bitCentOS/disk2
gpgcheck=1
gpgkey=file:///yada/yada/yada/RPM-GPG-KEY-CentOS-6
The error i get is:
Code:
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
http://YumSvr/64bitCentOS/disk2/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror
updates
Setting up Install Process
...
Disk2 does not have a repomd.xml so the error is correct. But it then goes on to load the packages that are only in the disk2 Packages. If i leave out any mention of disk2 in the CentOS-Base.repo it shows the disk2 packages (disk1 repodata list them) but fails to find them in disk1's hierarchy.

What is the proper way to point to the disk2 structure (if there is one) since the iso doesn't have a repomd file of its own.

Thanks Rick.
 
Old 02-28-2013, 11:12 PM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 17,814

Rep: Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553Reputation: 2553
Basically, you don't need to specify so deep in the dir structure; see this howto https://code.google.com/p/iredmail/w...Yum_Repository
 
Old 03-01-2013, 08:56 AM   #3
oly_r
Member
 
Registered: Dec 2011
Posts: 31

Original Poster
Rep: Reputation: Disabled
Thanks, i'll try that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving LVM from disk2 t o disk1 DragonFly2 Linux - Server 14 04-11-2011 03:43 PM
FEDORA 10 - yum repo config issue - cannot see extra packages manuleka Linux - Newbie 17 02-23-2009 08:29 AM
Dual Boot (Disk1-Linux, Disk2-Windows) Slipstream2006 Linux - General 5 07-28-2007 11:32 PM
Yum core repo baseurl issue ian0115 Linux - Software 1 07-03-2006 02:08 AM
solaris-9-i386-disk2.iso jasmeet93 Solaris / OpenSolaris 5 07-19-2005 02:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration