-   Linux - Software (
-   -   yum problems (

canyon289 11-12-2004 10:38 PM

yum problems
yum wasnt too well so i replaced the yum.conf with the one from
Now i get this error all the time
[root@localhost ~]# yum upgrade
Repository updates-released already added, not adding again
Repository base already added, not adding again
Setting up Upgrade Process
Setting up Repo: livna-stable
Cannot open/read repomd.xml file for repository: livna-stable
failure: repodata/repomd.xml from livna-stable: [Errno 256] No more mirrors to try.
[root@localhost ~]#

any way to fix it

drj000 11-13-2004 07:39 AM

I've been having the same problems. It looks like there was a change in the recent version of yum, and either some of the repositiories haven't been upgraded to fit the new format, and/or the url used in the yum.conf file needs to be changed.

I'm going to do a little more research into it today, if I find anything, I'll tell you, but in addition to the regular fe0dora repositories, here's the only one's I've been able to get to work so far:


name=Dag APT Repository


[atrpms-stable] #I suppose all the atrpm repos will work, but this is only one I use.
name=ATrpms for Fedora Core $releasever stable

Shade00 12-01-2004 06:11 AM

FC3 update
ok....this is to et u started.

the next phase i went through was to boost up the speed.
when i looked into it properly, i found that it was using the RPM's from the 4 CD distro set i downloaded.

next i set yum.conf to get the rpm's from an FTP on my local network. after getting the repomd.xml from:

inserted them to ftp://localserver/pub/base/repomd (i transferred them via ftp, so beware of ur chkmod)
yum upgrade, y/N = y
and bob's ur uncle :)

good luck, and spread the word.

(dependency hell is NOT my issue if u encounter it)

if any1 has found how to fix the updater....whisper it to me as well (

Rockfish 12-02-2004 07:25 AM

I encountered pretty much the same problem and tried to run it down last night. The quick description is that yum updated yum to a 2.1 version, and now yum won't work because all the repositories you have in your yum.conf are not set up with the repomd stuff. It looks like you may have tried to upgrade to core 3 with yum. If so, perhaps you need to make sure that your yum.conf now points to core 3 repositories, and I think there is also a new format for yum.conf that includes using some other files. I haven't dealt with that yet.

If you are still using core 2 and not trying to upgrade, we have the same problem. After visiting all the repositories in my yum.conf, I found that only ATrpms had yum 2.1.12. The at-stable site was set up properly for 2.1.12, but none of the other sites I visited were. I decided to downgrade yum to 2.07 and comment out the at-stable site (in yum.conf) for the time being. An alternative would be to stay at yum 2.1.12 and use only the ATrpms sites. You should look at the sites you are using and make your own decision.


Shade00 12-02-2004 10:11 AM

FC2 FC3 update via yum
sorry 'bout that.
u fix the fedora.repo to ur local (or any) mirror.

if i failed to specify, thatz what and how i did it

All times are GMT -5. The time now is 11:06 AM.