LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-07-2015, 06:09 AM   #1
standards
Member
 
Registered: May 2015
Posts: 54

Rep: Reputation: Disabled
Unhappy Yum Dependency Tree Broken with RHEL 7 / Cent OS


Most of the time, when i install a packacge like VLC,this (Verbose Output) happens:


Normal Output
Code:
Trying other mirror.
Loading mirror speeds from cached hostfile
 * epel: mirror.us.leaseweb.net
 * rpmforge: mirror.us.leaseweb.net
 * rpmfusion-free-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
Resolving Dependencies
--> Running transaction check
---> Package vlc.x86_64 0:2.0.10-1.el6 will be installed
--> Processing Dependency: vlc-core(x86-64) = 2.0.10-1.el6 for package: vlc-2.0.10-1.el6.x86_64
--> Processing Dependency: libcaca.so.0()(64bit) for package: vlc-2.0.10-1.el6.x86_64
--> Processing Dependency: libaa.so.1()(64bit) for package: vlc-2.0.10-1.el6.x86_64
--> Processing Dependency: libxcb-keysyms.so.1()(64bit) for package: vlc-2.0.10-1.el6.x86_64
--> Processing Dependency: libvlccore.so.5()(64bit) for package: vlc-2.0.10-1.el6.x86_64
--> Processing Dependency: libminizip.so.1()(64bit) for package: vlc-2.0.10-1.el6.x86_64
--> Running transaction check
---> Package aalib-libs.x86_64 0:1.4.0-0.22.rc5.el7 will be installed
---> Package libcaca.x86_64 0:0.99-0.17.beta17.el7 will be installed
--> Processing Dependency: libglut.so.3()(64bit) for package: libcaca-0.99-0.17.beta17.el7.x86_64
---> Package minizip.x86_64 0:1.2.7-13.el7 will be installed
---> Package vlc-core.x86_64 0:2.0.10-1.el6 will be installed
--> Processing Dependency: live555date(x86-64) = 2012.04.27 for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libpostproc.so.52(LIBPOSTPROC_52)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libthreadutil.so.6()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libtwolame.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavcodec.so.53()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmtp.so.8()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libdvbpsi.so.7()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libudev.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libva-x11.so.1()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmpeg2.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libupnp.so.6()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libkate.so.1()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libixml.so.2()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libzvbi.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgroupsock.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libdc1394.so.22()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libx264.so.120()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libdirac_encoder.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libpostproc.so.52()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libBasicUsageEnvironment.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libtiger.so.5()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libcddb.so.2()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libdirac_decoder.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libliveMedia.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libva.so.1()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavutil.so.51()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libUsageEnvironment.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: liba52.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libfaad.so.2()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libebml.so.3()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libdca.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libproxy.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmatroska.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libavformat.so.53()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgme.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
---> Package xcb-util-keysyms.x86_64 0:0.3.9-5.el7 will be installed
--> Running transaction check
---> Package a52dec.x86_64 0:0.7.4-15.el6.3 will be installed
---> Package dirac-libs.x86_64 0:1.0.2-14.el7 will be installed
---> Package faad2-libs.x86_64 1:2.7-2.el6.3 will be installed
---> Package ffmpeg-libs.x86_64 0:0.10.15-1.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_cdda.so.0(CDIO_CDDA_0)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_paranoia.so.0(CDIO_PARANOIA_0)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libopenal.so.1()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libxvidcore.so.4()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: librtmp.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libschroedinger-1.0.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_paranoia.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_cdda.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libopenjpeg.so.2()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcelt0.so.1()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
---> Package freeglut.x86_64 0:2.8.1-3.el7 will be installed
---> Package game-music-emu.x86_64 0:0.6.0-5.el7 will be installed
---> Package libcddb.x86_64 0:1.3.2-12.el7 will be installed
---> Package libdc1394.x86_64 0:2.2.2-3.el7 will be installed
---> Package libdca.x86_64 0:0.0.5-6.el6 will be installed
---> Package libdvbpsi.x86_64 0:0.2.2-2.el6 will be installed
---> Package libkate.x86_64 0:0.4.1-4.el7 will be installed
---> Package libmodplug.x86_64 1:0.8.8.5-3.el7 will be installed
---> Package libmpeg2.x86_64 0:0.5.1-9.el6 will be installed
---> Package libtiger.x86_64 0:0.3.4-7.el7 will be installed
---> Package libupnp.x86_64 0:1.6.19-2.el7 will be installed
---> Package libva.x86_64 0:1.2.1-3.el7 will be installed
---> Package lirc-libs.x86_64 0:0.9.1a-4.el7 will be installed
---> Package live555.x86_64 0:0-0.37.2012.04.27.el6 will be installed
---> Package twolame-libs.x86_64 0:0.3.13-2.el6 will be installed
---> Package vlc-core.x86_64 0:2.0.10-1.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmtp.so.8()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libudev.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libebml.so.3()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libproxy.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmatroska.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
---> Package x264-libs.x86_64 0:0.120-5.20120303.el6 will be installed
---> Package zvbi.x86_64 0:0.2.33-15.el7 will be installed
--> Running transaction check
---> Package ffmpeg-libs.x86_64 0:0.10.15-1.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_cdda.so.0(CDIO_CDDA_0)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_paranoia.so.0(CDIO_PARANOIA_0)(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_paranoia.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcdio_cdda.so.0()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libopenjpeg.so.2()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
--> Processing Dependency: libcelt0.so.1()(64bit) for package: ffmpeg-libs-0.10.15-1.el6.x86_64
---> Package lame-libs.x86_64 0:3.99.5-1.el6 will be installed
---> Package librtmp.x86_64 0:2.3-3.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: librtmp-2.3-3.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: librtmp-2.3-3.el6.x86_64
---> Package openal-soft.x86_64 0:1.16.0-2.el7 will be installed
---> Package schroedinger.x86_64 0:1.0.11-4.el7 will be installed
---> Package vlc-core.x86_64 0:2.0.10-1.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmtp.so.8()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libudev.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libebml.so.3()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libproxy.so.0()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
--> Processing Dependency: libmatroska.so.4()(64bit) for package: vlc-core-2.0.10-1.el6.x86_64
---> Package xvidcore.x86_64 0:1.3.2-3.el6 will be installed
--> Finished Dependency Resolution
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libass.so.4()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libcdio_cdda.so.0()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26()(64bit)
Error: Package: librtmp-2.3-3.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libcdio_paranoia.so.0()(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libudev.so.0()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libcdio_cdda.so.0(CDIO_CDDA_0)(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libass.so.4()(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libcdio_paranoia.so.0(CDIO_PARANOIA_0)(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libproxy.so.0()(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libmatroska.so.4()(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libebml.so.3()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libcelt0.so.1()(64bit)
Error: Package: ffmpeg-libs-0.10.15-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libopenjpeg.so.2()(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libmtp.so.8()(64bit)
Error: Package: librtmp-2.3-3.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: vlc-core-2.0.10-1.el6.x86_64 (rpmfusion-free-updates)
           Requires: libgnutls.so.26()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 
Old 05-07-2015, 07:27 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
You are using the "rpmfusion.repo" for RHEL 6 / CentOS 6.
Which means that vlc also requires "CentOS 6 / Fedora 12 "dependencies".

Example : libopenjpeg.so.2 is a { RHEL 6 / CentOS 6 / Fedora 12 } file.


RHEL 7 / Cent OS 7 : Based on Fedora ~18, ~19.
I.e. quite different packages, files.


-

Last edited by knudfl; 05-07-2015 at 07:32 AM.
 
Old 05-07-2015, 07:43 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Available for RHEL 7 / Cent OS 7 is vlc, mplayer, HandBrake-gui ,,, from ...
http://www.unixmen.com/nux-dextop-a-...pm-repository/




-
 
Old 05-07-2015, 03:20 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,628

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
you can not mix the CentOS 6 repos with CentOS 7

the two operating systems are VERY DIFFERENT

uninstall ALL centos6 rpms
Code:
su -
rpm -qa | grep el6
and uninstall EVERYTHING in that list

then remove the centos 6 repo
and install the CEntOS 7 repos
 
Old 05-07-2015, 05:39 PM   #5
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
MY repolist:
adobe-linux-x86_64 Adobe Systems Incorporated 2
!base CentOS-$releasever Base 8,465
!epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_6 7,763
!extras CentOS-7 - Extras 84
!google-chrome google-chrome 3
!rpmforge RHEL $releasever - RPMforge.net - dag 245
!rpmfusion-free-updates/x86_64 RPM Fusion for EL 6 - Free - Updates 293
!rpmfusion-nonfree-updates/x86_64 RPM Fusion for EL 6 - Nonfree - Updates 87
!updates CentOS-7 - Updates 362
repolist: 17,315
 
Old 05-07-2015, 05:52 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Re #5.

Read post #4, #2.
!rpmfusion-free-updates/x86_64 RPM Fusion for EL 6 - Free - Updates 293
!rpmfusion-nonfree-updates/x86_64 RPM Fusion for EL 6 - Nonfree - Updates 87
... are not usable for RHEL 7 / Cent OS 7 !

And : !rpmforge RHEL $releasever - RPMforge.net - dag 245
.. is not compatible with rpmfusion, epel.


-
 
Old 05-07-2015, 07:14 PM   #7
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
I did that.Now my repolist is

!RHEL_7_Disc RHEL_7_x86_64_Disc 11
adobe-linux-x86_64 Adobe Systems Incorporated 2
base CentOS-$releasever Base 8,465
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 7,763
extras CentOS-7 - Extras 84
google-chrome google-chrome 3
updates CentOS-7 - Updates
And I cant install VLC
 
Old 05-08-2015, 05:27 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Re #7.

""I cant install VLC"" : No, of course not. The `nux-dextop.repo' is missing !

Please read post #3.
 
Old 05-08-2015, 06:09 AM   #9
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
I installed vlc.But how can i prevent this from hapening again
 
Old 05-08-2015, 07:04 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Re #9.

Prevent what from happening ? ?


If you read all the above postings carefully, you actually already have all the required information, I think.

And : John VV can tell you how to use 'yum-priorities'
http://wiki.centos.org/PackageManagement/Yum/Priorities


-

Last edited by knudfl; 05-08-2015 at 07:07 AM.
 
Old 05-08-2015, 01:25 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,628

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
i do expect people to do some research

the cent wiki for installing software has WARNINGS!!! all over it
and informs one to use that plugin

but rpmfusion should not cause problems
now if you were to mix rpmfusion and rpmforge ??????

Quote:
I installed vlc.But how can i prevent this from hapening again
but to keep your problem from happining
DO NOT install software repos FOR A DIFFERENT OPERATING SYSTEM


basically you were trying to install software for the equivalent of " Windows XP" on a "Windows 8.1" operating system
--- that will not work out well on windows or Apple's mac
or in linux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check dependency and install application from internet in red-hat,ubuntu,cent-os . prasad1990 Linux - Newbie 6 05-01-2015 08:20 AM
RHEL yum broken aoscott Red Hat 10 03-09-2013 03:53 AM
Display of dependency tree fransdb Linux - Software 6 05-18-2011 04:21 PM
RHEL 5 Yum Update Errors, Pup Broken - Help. maxvonseibold Red Hat 1 08-16-2007 06:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration