LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-13-2015, 02:08 AM   #1
kohshan99
Member
 
Registered: Sep 2012
Posts: 71

Rep: Reputation: Disabled
Question Your PHP version does not satisfy that requirement.


hey‏

how to fix that issue? getting error that your PHP version does not satisfy that requirement...

Quote:
root@iptv:~/source# ./composer.phar install
Warning: This development build of composer is over 30 days old. It is recommended to update it by running "./composer.phar self-update" to get the latest version.
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for fabpot/goutte v2.0.3 -> satisfiable by fabpot/goutte[v2.0.3].
- fabpot/goutte v2.0.3 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
Problem 2
- Installation request for guzzlehttp/guzzle 5.2.0 -> satisfiable by guzzlehttp/guzzle[5.2.0].
- guzzlehttp/guzzle 5.2.0 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
Problem 3
- Installation request for guzzlehttp/ringphp 1.0.6 -> satisfiable by guzzlehttp/ringphp[1.0.6].
- guzzlehttp/ringphp 1.0.6 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
Problem 4
- Installation request for guzzlehttp/streams 3.0.0 -> satisfiable by guzzlehttp/streams[3.0.0].
- guzzlehttp/streams 3.0.0 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
Problem 5
- Installation request for react/promise v2.2.0 -> satisfiable by react/promise[v2.2.0].
- react/promise v2.2.0 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
Problem 6
- fabpot/goutte v2.0.3 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
- symfony/framework-standard-edition 2.6.x-dev requires fabpot/goutte ~2.0 -> satisfiable by fabpot/goutte[v2.0.3].
- Installation request for symfony/framework-standard-edition 2.6.x-dev -> satisfiable by symfony/framework-standard-edition[2.6.x-dev].
 
Old 04-13-2015, 03:03 AM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Hi...

It looks like you will need to upgrade your version of PHP, as Composer needs at least version 5.4.0. You can find PHP of different versions here. Also, if you you are using a distribution like Ubuntu or Debian, perhaps a newer version (that meets the minimum requirement,) is available in the repositories. Just use your package manager or a terminal to update.

Regards...

Last edited by ardvark71; 04-13-2015 at 04:13 AM. Reason: Corrections.
 
Old 04-13-2015, 03:41 AM   #3
kohshan99
Member
 
Registered: Sep 2012
Posts: 71

Original Poster
Rep: Reputation: Disabled
when i run
Quote:
root@iptv:~/source# ./composer.phar update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- fabpot/goutte v2.0.3 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
- fabpot/goutte v2.0.2 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
- fabpot/goutte v2.0.1 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
- fabpot/goutte v2.0.0 requires php >=5.4.0 -> your PHP version does not satisfy that requirement.
- Installation request for fabpot/goutte ~2.0 -> satisfiable by fabpot/goutte[v2.0.0, v2.0.1, v2.0.2, v2.0.3].
even i update from ubuntu repositories.. still getting these errors
 
Old 04-13-2015, 03:54 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,516

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
https://getcomposer.org/doc/00-intro.md
"" Composer is a tool for dependency management in PHP. ""

Why do you want a version of 'composer' that doesn't match you php version ?
 
Old 04-13-2015, 04:21 AM   #5
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by kohshan99 View Post
even i update from ubuntu repositories.. still getting these errors
Hi...

Hmmm. What version is reported to be installed? I also found this page, if it helps.

Regards...
 
1 members found this post helpful.
Old 04-14-2015, 11:47 AM   #6
kohshan99
Member
 
Registered: Sep 2012
Posts: 71

Original Poster
Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by ardvark71 View Post
Hi...

Hmmm. What version is reported to be installed? I also found this page, if it helps.

Regards...

Thank you soo much.. it works..
 
Old 04-14-2015, 05:12 PM   #7
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by kohshan99 View Post
Thank you soo much.. it works..
You're welcome, glad you got it going!

If you would, please mark this thread as "SOLVED."

Regards...
 
  


Reply

Tags
iptv, php5, php5 apache mysql, ubuntu 12.10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Minimum Hardware requirement for running RHEL 7 version sathish6105 Linux - Hardware 7 04-03-2015 11:56 AM
basic requirement to work on redhat version 9 sania Linux - Software 9 02-02-2012 02:36 AM
How strict is the host system kernel version requirement? DrSpatula Linux From Scratch 3 11-07-2011 08:46 PM
Newer Library version doesn't satisfy dependency ChantCd Linux - Software 4 12-02-2010 11:09 AM
Os requirement info needed Red Hat 5,6,7 version sylvaincyr Linux - Newbie 4 03-18-2010 10:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration