LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-17-2006, 01:52 PM   #1
dus3d
LQ Newbie
 
Registered: Apr 2006
Posts: 6

Rep: Reputation: 0
you don't have permission to access / on this server


Hi,

I have installed a web server on my mandrake 10.1 box, I wonder if you have the same problem as mine, I can access my webpage using my IP, but i can't seem to access it whenever I add a virtual server. I have set appropriate permissions to /mydomain/www on my individual virtual server but i can't see it on the net. Instead i get this "you don't have permission to access / on this server" message. I have added "DirectoryIndex" in the Vhosts.conf file and still no progress. Also, I see the same no permission message when I try my IP on the browser. Will someone help me on this?
 
Old 04-17-2006, 02:16 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
I'm not having the same problem as you, as i'm not having a problem, wonder why you think someone has to have a problem to help you... anyway, directoryindex simply lists which files to use as index pages, e.g. index.html index.php default.htm etc... you want the Indexes option: http://httpd.apache.org/docs/2.0/mod/core.html#options
 
Old 04-17-2006, 03:25 PM   #3
mikeyt_333
Member
 
Registered: Jun 2001
Location: Up in the clouds
Distribution: Fedora et al.
Posts: 353

Rep: Reputation: 30
Are you running SELinux? Check the security context of the files in questions:

Code:
$ ls -Z *
You should see something like:

Code:
drwxr-xr-x  root     root     system_u:object_r:httpd_sys_content_t error
The important part here is the system_ubject_r:httpd_sys_content_t. If they aren't set to that, and SELinux is set to enforce, you need to do the following:

Code:
$ chcon system_u:object_r:httpd_sys_content_t * -R
To change the context of each file within the directory and its subdirectories. If you don't need a recursive change remove the -R from the command. Restart httpd, and if SELinux is the culprit, this will resolve your issues. The log file to look at to confirm SELinux problems is /var/log/audit/audit.log. If this fixes your problem, look into http://www.chinaitpower.com/2005Sept...13/201367.html for a quick rundown of SELinux policies and applications.

HTH,
Mike.
 
Old 04-18-2006, 01:23 AM   #4
dus3d
LQ Newbie
 
Registered: Apr 2006
Posts: 6

Original Poster
Rep: Reputation: 0
no i am not using SELinux, and the # ls -Z doesn't work either, the DirectoryIndex i made was to make the website point to the index file, which is a .htm , i thought maybe the " permission " problem might be that the website cannot find the proper index file. I've googles on it and done everything but there seem to be no solution.
 
Old 04-18-2006, 02:31 AM   #5
mikeyt_333
Member
 
Registered: Jun 2001
Location: Up in the clouds
Distribution: Fedora et al.
Posts: 353

Rep: Reputation: 30
Can you post your configs?
 
Old 04-19-2006, 12:43 AM   #6
dus3d
LQ Newbie
 
Registered: Apr 2006
Posts: 6

Original Poster
Rep: Reputation: 0
this is my '/etc/httpd/conf/vhosts/Vhosts.conf' config, the only file i've changed sinced i made a clean install
NameVirtualHost *
<VirtualHost *>
ServerName www.domain.tld
ServerPath /domain
DocumentRoot /home/user/domain
DirectoryIndex index.html index.htm index.shtml default.cgi default.html default.htm
#</VirtualHost>

I haven't changed anything from the 'httpd.conf' file, but a few days ago virtual hosting worked using the same settings, but after i installed Linneighborhood,i can't access virtal hosted sites.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
You don't have permission to access /~username on this server. sijolinux Linux - Newbie 5 01-03-2008 06:19 PM
Apache Vhost( You don't have permission to access / on this server.) trekgraham Linux - Software 3 07-08-2004 11:01 AM
After file oops ? Forbidden You don't have permission to access / on this server. leongoogs Linux - Newbie 3 04-13-2004 10:27 AM
You don't have permission to access / on this server. jkpalmer52 Linux - General 4 01-27-2004 05:05 PM
You don't have permission to access / on this server jaydave Linux - Networking 1 03-15-2003 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration