-   Linux - Software (
-   -   Yet another x server thread, XFCE Fdra 10 - fails to start on non-root acc only (

cvandeve 03-25-2009 10:40 AM

Yet another x server thread, XFCE Fdra 10 - fails to start on non-root acc only

I know half of you always say give all the info, and the other half see a long post and fail to read all of it, so here's hoping someone can help:)

When trying to login to xfce/fedora10 the screen turns black, turns off, then loads back to the login prompt (gdm? whatever login manager xfce uses)

I do take updates as they come along, and I do have nvidia, so I tried -- in order (and each step failed to work)

1. nvidia-xconfig
2. yum reinstall kmod-nvidia then nvidia-xconfig
3. yum remove kmod-nvidia, reboot, edit /etc/X11/xorg.conf to use 'nv'

and about this point I realized what I usually do to fix rebooting/nvidia-kernel issues wasn't working, I checked for update on kernel-devel (none), and checked on updates for the x11-xserver-xorg or whatever package, and nothing.

I moved into a console and found that trying to startx said .xauthority file was already in use, so I tried to kill anything using ps aux | grep x that contained either xorg or xauthority or x11 or what-not... I was able to launch the xserver as ROOT... no problems! so I logged out and from the console tried to login as my main account and... it failed:(

I rebooted into init 1 and tried startx from my user account and received

cannot connect to system bus: failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

but that's probably 'cause of init1.... I tried from init 3, and received

unable to access file /home/van/.ICEAuthority Permission Denied.
unable to access file /home/van/.Xauthority Permission denied.

I change xauthority from root:root to van:van, but I can't find ICEAuthority in ~/

I even tried uninstalling and reinstalling the xserver-xorg-conf package from yum, and using vanilla drivers, but I still can't login to van under the graphical server, while the root account works without a problem.

the xorg.0.log file shows the loading of the modules, and no clear errors. The only thing I can see that isn't normal is that it says ACPI: Failed to connect to the ACPI event daemon; the daemon may not be running or the acpidSocketPath X configuration option may not be setup correctly...

daemon is running, and if the socketpath wasn't set up correctly, why would it work under root but not user?

I know I'm on a long run on sentence, I apologize. thank you for help in adv.

ronlau9 03-25-2009 02:04 PM

Easy way out start which the special spin off Fedora XFCE
There is special spin off for both 32 bits 64 bits version

All times are GMT -5. The time now is 04:04 AM.