LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-06-2005, 10:07 AM   #1
paul_dundee
Member
 
Registered: Mar 2005
Location: Scotland
Distribution: FC3
Posts: 39

Rep: Reputation: 15
Yet another VNC problem


I know this has been posted before, but after scouring the internet for over a week i am still no further forward.

how is it possible to specify which port vncserver listens on?

I would like to use 80, i know how to configure the viewer to work on 80.

any help appreciated.
 
Old 03-06-2005, 10:33 AM   #2
d_t_baker
Member
 
Registered: Oct 2003
Location: AU
Distribution: Ubuntu
Posts: 57

Rep: Reputation: 15
a little lesson in rtfm. or in my case grep the f** manual

gook:/home/dbaker# vncserver --help
usage: vncserver [:<number>] [-name <desktop-name>] [-depth <depth>]
[-geometry <width>x<height>]
[-pixelformat rgbNNN|bgrNNN]
<Xvnc-options>...
vncserver [-clean] -kill :<number>

ooooooooooooooo we have to specify some Xvnc options.......

gook:/home/dbaker# Xvnc --help 2>&1|grep -i port
-bs disable any backing store support
-pn accept failure to listen on all ports
-nopn reject failure to listen on all ports
-su disable any save under support
-port port-num UDP port number to send messages to
-rfbport port TCP port for RFB protocol
-httpport port port for HTTP

arr there it is... u seem noobish, have u looked at x11vnc ?

d.
 
Old 03-06-2005, 10:44 AM   #3
paul_dundee
Member
 
Registered: Mar 2005
Location: Scotland
Distribution: FC3
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by d_t_baker
a little lesson in rtfm. or in my case grep the f** manual

gook:/home/dbaker# vncserver --help
usage: vncserver [:<number>] [-name <desktop-name>] [-depth <depth>]
[-geometry <width>x<height>]
[-pixelformat rgbNNN|bgrNNN]
<Xvnc-options>...
vncserver [-clean] -kill :<number>

ooooooooooooooo we have to specify some Xvnc options.......

gook:/home/dbaker# Xvnc --help 2>&1|grep -i port
-bs disable any backing store support
-pn accept failure to listen on all ports
-nopn reject failure to listen on all ports
-su disable any save under support
-port port-num UDP port number to send messages to
-rfbport port TCP port for RFB protocol
-httpport port port for HTTP

arr there it is... u seem noobish, have u looked at x11vnc ?

d.
I've been trying to tunnel using SSH on 80 which works internally, but will not work outside. Firewall is set to forward port 80 traffic to that machine.

Will try the -rfbport 80 later. thanks.
 
Old 03-06-2005, 05:07 PM   #4
paul_dundee
Member
 
Registered: Mar 2005
Location: Scotland
Distribution: FC3
Posts: 39

Original Poster
Rep: Reputation: 15
Please tell me what I am doing wrong here.

[root@fedora1 paulc]# Xvnc -rfbport 80

Xvnc version 4.0 - built Jun 14 2004 12:01:28
Underlying X server release 40201000, The XFree86 Project, Inc


Sun Mar 6 22:08:18 2005
vncext: VNC extension running!
vncext: vncExtInit: unable to bind listening socket: Address already in
use (98)
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
[root@fedora1 paulc]#
 
Old 03-06-2005, 05:26 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
are you not using ssh on port 80 already? if you can ssh direct to your machine, then you want to be tunneling port 5901 (i think that's it offhand) for display :1 etc...
 
Old 03-06-2005, 05:40 PM   #6
paul_dundee
Member
 
Registered: Mar 2005
Location: Scotland
Distribution: FC3
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
are you not using ssh on port 80 already? if you can ssh direct to your machine, then you want to be tunneling port 5901 (i think that's it offhand) for display :1 etc...
I can tunnel using ssh on 80 internally, but from addresses outsite my lan i cannot ssh on 80. However on 22, i can ssh from anywhere. The problem is my company firewall will only allow traffic through 80. Although i have virtual pc with dialup the connection is a nightmare.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC problem gauge73 Linux - Networking 13 01-27-2009 01:34 AM
VNC Problem RySk8er30 Mandriva 2 09-05-2005 06:57 PM
little vnc problem -- please help ruwach Linux - Software 3 12-06-2004 11:47 PM
VNC Problem Wolf-67 Linux - Newbie 1 10-01-2004 07:19 PM
VNC problem Fulkan Linux - Software 1 10-01-2004 07:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration