LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   yet another mplayer install and codec question... (https://www.linuxquestions.org/questions/linux-software-2/yet-another-mplayer-install-and-codec-question-188391/)

NonSumPisces 06-01-2004 07:47 AM

yet another mplayer install and codec question...
 
I've installed gmplayer many timeees now, but it won't run win32 codecs.
This is the summary of my latest try at it.

I've put the win32 codecs in the usr/lib/win32 dir and when I compile, I use this string:

./configure --enable-gui --with-win32libdir=/usr/lib/win32 --disable-runtime-cpudetection

I've also removed the codecs.conf file in the ~/.mplayer dir prior to the install.

When I compile mplayer, the shell prints this:

Enabled optional drivers:
Input: ftp network edl tv matroska(internal) mpdvdkit2 vcd dvb
Codecs: qtx libavcodec real dshow/dmo win32 faad2(internal) libmpeg2 liba52 mp3lib libvorbis libmad
Audio output: alsa1x esd arts oss nas mpegpes(dvb)
Video output: xvidix cvidix vesa jpeg png mpegpes(dvb) fbdev opengl dga xv x11 xover tga
Disabled optional drivers:
Input: tv-v4l2 tv-v4l tv-bsdbt848 live.com cdda dvdread smb
Codecs: opendivx xvid libdv xanim libtheora liblzo gif
Audio output: sgi sun dxr2 win32 sdl macosx
Video output: winvidix bl zr zr2 dxr3 dxr2 directx sdl gif89a svga caca aa ggi xmga mga xvmc directfb tdfx_vid tdfxfb 3dfx quartz


Both make and make install works smoothly (it seems), but mplayer won't even run at all now.

What do I try next?

Hammett 06-01-2004 08:09 AM

Wow, wierd....That should be working. Have you tried to install from rpm pakage? Also try not to put -with-win32libdir=/usr/lib/win32, as the script itself looks on /usr/lib/win32.

320mb 06-01-2004 08:15 AM

Quote:

./configure --enable-gui --with-win32libdir=/usr/lib/win32 --disable-runtime-cpudetection
change the directory to read
Quote:

./configure --enable-gui --with-codecslibdir=/usr/lib/codecs --disable-runtime-cpudetection

NonSumPisces 06-01-2004 08:30 AM

Thanks ppl =)

./configure --enable-gui --with-codecslibdir=/usr/lib/codecs --disable-runtime-cpudetection

didn't work, but

./configure --enable-gui --with-codecdir=/usr/lib/codecs --disable-runtime-cpudetection

did work work for the compilation, I'll update this post when I know if mplayer works :)

*crossing fingers*

And oh, Hammett, I've tried the rpm solution but it didn't work at all :-/ My system is strange. I'm thinking about switching to Slackware or LFS when I'm more familiar with the linux structure and usage. Then I'll atleast know what's on my system, where it is and how it's configured...

NonSumPisces 06-01-2004 08:40 AM

Alright :) That did the trick :) Strangly enough, the init log for mplayer says it's not compiled with the --disable-runtime-cpudetection option, but I don't care now, the app works and it plays the files I want it to play :)

Thx ppl.

Btw, 320mb, what's your experience of LFS and Slackware?


All times are GMT -5. The time now is 05:57 AM.