LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-10-2003, 07:06 PM   #1
parkus
LQ Newbie
 
Registered: Dec 2003
Distribution: Gentoo 1.4
Posts: 2

Rep: Reputation: 0
yet another grub problem


heres my situation, 2 hard drives, linux is on the master drive, windows 2000 is slave
1 linux split up like this:
hda1 - boot
hda2 - swap
hda3 - root

1 windows 2000 drive all to itself

my grub.conf looks like this

Code:
timeout 10
default 0

title Gentoo
root (hd0,0)
kernel (hd0,0)/boot/bzImage root=/dev/hda3

title Windows 2000
map (hd0) (hd1)
map (hd1) (hd0)
chainloader (hd1,0)+1

linux boots like i want, which is good, but whenever i pick windows i get error 21 cant be found....any help majorly appecirated.


ps. i dont know if this matters but when i unplug out my linux hd and set up the windows to master, windows boots correct....

Last edited by parkus; 12-10-2003 at 07:55 PM.
 
Old 12-10-2003, 07:55 PM   #2
mickboda
Member
 
Registered: Jul 2002
Location: Sydney
Distribution: Kubuntu Edgy
Posts: 74

Rep: Reputation: 15
Windows is the problem child here

Windows will not work on a second drive if it can not write enties to the master drive. You need to follow the rules when installing a win/lin dual boot.

Install windows first, then Linux

Regards

Mick
 
Old 12-10-2003, 08:04 PM   #3
mickboda
Member
 
Registered: Jul 2002
Location: Sydney
Distribution: Kubuntu Edgy
Posts: 74

Rep: Reputation: 15
Ohppps sorry about the double post

Your on the right track with unplaugging your linux drive.

Try to swap the drive order then edit grub.cong to reflect the changes. I'm not sure what your editted grub.conf will look like, don't have linux a linux box easily accesible at work.

Regards

Mick
 
Old 12-11-2003, 11:42 AM   #4
parkus
LQ Newbie
 
Registered: Dec 2003
Distribution: Gentoo 1.4
Posts: 2

Original Poster
Rep: Reputation: 0
are you 100% sure there isnt a way to trick winblows into booting?
 
Old 12-11-2003, 12:41 PM   #5
BrianNJ
Member
 
Registered: Jul 2003
Distribution: Gentoo 2004.0
Posts: 157

Rep: Reputation: 30
Re: yet another grub problem

when i got a new harddrive, i put the harddrive that has my window's parition as a slave. i don't have it in front of me, but my windows entry in grub is more like this...

Code:
title WindowsXP
map (hd0) (hd1)
map (hd1) (hd0)
root(hd1,0)
chainloader +1
edit: my window's partition is the first partition on my secondary drive (hence hd(1,0))

don't fudge with boot.ini on your window's partition. i had to use the rescue disk to fix that one!

Last edited by BrianNJ; 12-11-2003 at 12:42 PM.
 
Old 12-11-2003, 07:06 PM   #6
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
you can try placing a 'makeactive' in your win section.

note that using grub 'e' and 'c' commands you don't need to reboot into linux each time to experiment, only to make changes permanent.

You CAN make it work. However, in this particular case, the easiest thing would be:
1) edit your fstab and change any hda to hdb (and vv)
2)edit as follows your grub.conf:
Code:
timeout 10
default 0

title Gentoo
root (hd1,0)
kernel /boot/bzImage root=/dev/hdb3

title Windows 2000
rootnoverify (hd0,0)
chainloader +1
3) installgrub in (hd1) (NOT (hd1,0)!!)
4) shutdown and swap disk jumpers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another GRUB problem eqxro Linux - Software 3 08-04-2004 10:27 AM
HDD problem, scancode problem and grub EJ_INSIDE Debian 2 07-15-2004 10:36 AM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
grub problem jigs Linux - Newbie 7 09-18-2003 01:16 PM
GRUB problem pupunk98 Linux - Newbie 7 12-26-2002 05:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration