LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-19-2002, 12:48 PM   #1
tied2
Member
 
Registered: Jun 2002
Location: Florida
Distribution: Redhat, FreeBSD, FC 6
Posts: 220

Rep: Reputation: 30
Talking Yes ! Another mplayer question


(OS) RH 7.3

I installed mplayer the other night and all is well except one thing when I try to play a DivX file I get a error: "could not initialize audio codec! -> nosound" any Ideas? the sound works in all other file formats

Also can mplayer read a dvd from a regular cdrom drive? or do I need to swap out my dvd rom from my wintendo box?

_______________________________________


Thanks !
 
Old 09-19-2002, 12:58 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
well what format is the sound in this file? be aware that "divx" is only the way that the video stream is encoded inside an avi file, and actually has nothign at all to do with the sound.

and erm... no computer can read dvd's from a cdrom drive, something of a fish needing a bicycle situation. cdrom drives can't read dvd's end of story.
 
Old 09-20-2002, 06:57 PM   #3
tied2
Member
 
Registered: Jun 2002
Location: Florida
Distribution: Redhat, FreeBSD, FC 6
Posts: 220

Original Poster
Rep: Reputation: 30
it seems I need a audio codec win32ACM I serched the web and found a few sites but no rpms can I just copy and paste the codec into the proper file??? What would it be? some lib file?

thanks
 
Old 09-20-2002, 07:21 PM   #4
tied2
Member
 
Registered: Jun 2002
Location: Florida
Distribution: Redhat, FreeBSD, FC 6
Posts: 220

Original Poster
Rep: Reputation: 30
Ok I fixed it , I just created the dir. it was looking for and copyed in the win32codec file
Thanks for your help Chris
 
Old 09-21-2002, 01:37 AM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
How's about if:
mplayer -vo xv filename.avi
isn't working? It gives the error that the -vo option isn't supported. But when I run:
mplayer -vo help
xv is listed.

Any ideas?
 
Old 09-21-2002, 02:55 AM   #6
exigent
Member
 
Registered: Aug 2002
Distribution: damnsmalllinux
Posts: 205

Rep: Reputation: 30
master, did you try to run mplayer without any options?
 
Old 09-21-2002, 03:34 AM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
No, I haven't. I can run it however with -vo x11 and -vo xvidix, but not with xv. I was able to do it before (on the same setup), but I guess this time during ./configure I left something out. At least that is what I am thinking. That or maybe I had something else installed that wasn't installed this time.

Cool
 
Old 09-21-2002, 04:40 AM   #8
exigent
Member
 
Registered: Aug 2002
Distribution: damnsmalllinux
Posts: 205

Rep: Reputation: 30
well, sounds like you have it all figured out...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer Question Whiteghost Linux - Software 3 10-11-2005 05:09 PM
Mplayer question.... Hammett Linux - Software 2 05-22-2004 04:12 PM
Question about mplayer vame87 Linux - General 10 08-27-2003 12:20 PM
Mplayer question gsmonk Linux - Software 5 03-08-2003 07:31 PM
Ok MPlayer question again digital bots Slackware 1 04-14-2002 08:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration