-   Linux - Software (
-   -   xwindows logout = black screen (

terrance 06-19-2003 12:44 AM

xwindows logout = black screen
hello all, I'm creating a new post here in hopes of greater readership, ah, I see a bunch of people having the same prob as myself and nothing tried so far has corrected it.

upon logout/reboot/shutdown from kde 3.1, xwindows appears to be shutting down followed by a black screen. key combinations such as ctrl+alt+backspace, etc don't work. I'm willing to try anything now

specs... gentoo(latest), kde3.1, nvidia drivers for a gf3 ti200.

things I've tried...
*generic drivers, generic nvidia, newest nvidia drivers,
*turning off framebuffer on boot (eg. vga=791 -> nothing), *different agp options(Nvagp = 0 or 1 or 2 in my xf86config),
*disabling power and blanking features in setterm

things I haven't tried... re-emerging xfree86 :( ouch

if anyone has any suggestions let'em rip,
thanks peeps.

wlfdgcrkz 06-19-2003 01:02 AM

I had that problem myself on a different os with with a different chipset however it sounds like the same basic thing.

terrance 06-20-2003 05:43 PM

Xwindows crashing system on logout
I have more details on what is happening here.
I thought that the screen may have been black with processes still running but after ssh'ing in from my other system and logging out of X, it appears X is crashing the whole kabootle:( omg!

so today I re-emerged Xfree without any improvements, bummer eh.

If anyone can suggest a solution, awesome! But I'll settle for a way to better pinpoint what exactly is happening. maybe a way to log it? I looked in /var/log/XFree86.0.log and only saw things that were initialized.... but? what really sucks is that the system is hardbooted after running Xwindows everytime.

bling bling 06-20-2003 05:58 PM

Do you get the same problem when you logout, reboot or shutdown from gnome:Pengy:

wlfdgcrkz 06-20-2003 09:11 PM

Your video card is not supported. Find a third party dirver.

X could not be killed cleanly. I would get a grey screen and the keyboard would freeze up caps lockoff etc. I had to do a hard reboot each time.
The problem was with an unsupported graphics card. S3 ProSavage km133. Previously it had only run on the generic vesa native to xfree86. It DID NOT RUN with the "savage" driver that was supplied with the x version out of the current FreeBSD ports.
I found a custom 3rd party S3 driver at which is in binary compiled specifically on freebsd and placed it in /usr/X11R6/lib/modules/drivers and then vi 'd /etc/X11/Xfree86config as follows:
Section "Device"
Identifier "Card0"
Driver "savage"
Option "ForceInit"

when x was restarted I was shocked to discover that i had a totally 100% functional card that permitted clean terminstions of x and subsequent friendly reboots (kind of important for clean filesystems). the last option fixed that bug preventing x from being cleanly shut down (preventing reboot). Additionally i could now make revinements on screen resolutions and such. Pretty cool because i love the current freebsd. Its fast even with kde and with blackbox or wmaker and opera its just plain sick.

terrance 06-22-2003 08:18 PM

x crashes on logout
A couple of other things I've tried lately.
*I've re-emerged nvidia-kernel and nvidia-glx
*yesterday I emerged gnome and re-emerged kde and it x still crashes on logout of either one. I'm still getting a black screen, sometimes a coloured one unresponsive keyboard and mouse. Everything works great before closing X.
*I've recompiled my kernel without extra frambuffer stuff, just have vesa vga framebuffer
*I don't have acpi support included in my kernel
* I looked at my xfree86.0.log with some people in a chat and it didn't seem to provide anything helpful.

I'm going to look into the power monitoring features in the kernel but I'm not sure where else to start looking.

is there a way to find out the cause of x crashing, such as a detailed log of the services being closed by X before it crashes?

terrance 06-23-2003 03:20 AM

another note about the Xfree86.log file, I set startx -logverbose 5 and scourded the file looking for a cause, there were no errors or warnings?
here are some highlights from it.... there was alot of data, if I've pasted too much for the forum let me know.

(==) ModulePath set to "/usr/X11R6/lib/modules"
Using vt 7
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
blabla...... then...
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4349
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4349
Module class: XFree86 Video Driver
(II) NVIDIA XFree86 Driver 1.0-4349 Thu Mar 27 19:02:58 PST 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xEE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce3 Ti 200
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0
(--) NVIDIA(0): Detected TV Encoder: Brooktree 869
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
blabla...lots of mode a Hz stuff
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): Display dimensions: (360, 270) mm
(--) NVIDIA(0): DPI set to (90, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
blabla...a wack of hexadec.
(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1280x1024/76Hz"
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) [GLX]: Initializing GLX extension
bla....the file almost ends there.

All times are GMT -5. The time now is 11:45 AM.