-   Linux - Software (
-   -   xwindows can't detect the mouse (

fatblueduck 04-20-2005 11:26 PM

xwindows can't detect the mouse
The mouse's light is on.
When I run dmesg, I can see that the optical mouse has been detected.
I have usb HID compiled in the kernel.

I can't figure out why my mouse is not detected.

For reasons which are tedious to explain, I am having to use XFree86 and the 2.4 kernel. The distribution that is being used is arch linux 0.6.

Before puking out, Xfree gives me these error messages.


(EE) xf86OpenSerial: Cannot  open device /dev/mouse
No such file or directory
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
no core pointer

Fatal server error:
Failed to initialize core devices

I've tried changing the mouse device around from /dev/mouse to /dev/input/mice, but that doesn't work

indeed, when I look in the /dev directory, there is not a further mouse or input directory inside of it.

Any ideas?

Tinkster 04-20-2005 11:40 PM

For usb rodents it's commonly


All times are GMT -5. The time now is 07:32 AM.