-   Linux - Software (
-   -   Xtest error compiling Synergy (

bpottle 09-15-2006 12:42 PM

Xtest error compiling Synergy
Trying to compile Synergy 1.3.1, I get this from ./configure:

checking for XTestQueryExtension in -lXtst... no
configure: error: You must have the XTest library to build synergy


[root@localhost synergy-1.3.1]# rpm -qa |grep Xtst


[root@localhost synergy-1.3.1]# locate Xtst

Tried doing 'yum install libXtst-devel', it installs successfully, but I get the same error from ./configure

What am I doing wrong? Is there some way I can specify where it looks when it's talking about "-lXtst"?

Thanks all,

quirks1 12-12-2009 10:09 AM

I know this is sort of a late reply, but other people might run into the same issue and find this thread while looking for a solution (just as I did):


yum install libXtst libXtst-devel libXext libXext-devel
cd /path/to/synergy/source
export CPPFLAGS='-I/usr/lib/X11'
./configure --prefix=/usr/local/synergy
sed -e 's/X_DISPLAY_MISSING 1/X_DISPLAY_MISSING 0/' -i'~' config.h
make install

You're welcome.

All times are GMT -5. The time now is 06:38 AM.