LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-27-2016, 12:10 AM   #1
borgward
Member
 
Registered: Apr 2005
Location: Austin, Texas
Distribution: Feather, Darn Small Linux
Posts: 381

Rep: Reputation: 17
xsane Thinks Printer is Scanner


Xsane sees Printer Not Scanner Linuxmint mate 17.3

Simple scan sees scanner, but xsane does not.

When I open xsane from menu I get "Error Failed to open device 'hpaio:/par/HP_Laserjet_1100? device=/dev/parport0':Invalid argument

Same message if I start from terminal.

When I start xsane from sudo it shows available devices:

Epson generic flatbed scanner [Epson2/dev/sg2]

Hewlett-Pac HP_Laserjet_1100 all-in-one [hpaio:/par/HP_Laserjet_1100?device=/dev/parport0]

I KNOW IT'S NOT GOOD TO RUN GRAPHICS FROM ROOT BUT NEED TO SO I CAN TROUBLESHOOT SO PLEASE STAY ON TOPIC!

The printer is not duplex, It does not have optional scanner added. During printer setup I indicated that the printer was not duplex.

Wonder why xsane does not see the Epson scanner if run from normal user, but does as root? and why it is seeing printer as a scanner? wrong driver?

Last edited by borgward; 06-27-2016 at 12:18 AM. Reason: Added info
 
Old 06-27-2016, 05:09 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Arch/Knoppix
Posts: 1,823
Blog Entries: 14

Rep: Reputation: 282Reputation: 282Reputation: 282
Question (1) probably has to do with permissions on the /dev/sg2. You'll probably have to modify a udev rule to get read&write permissions, or add your user to the appropriate group that does, eg wheel, lp, scanner or whatever for your setup.

Question (2) I'd reinstall the HP driver: I agree it's a misconfiguration. I assume you do have a laser jet 1100? Possibly, just possibly related to your user permission problem in #1, but don't know it could be.
 
Old 06-28-2016, 11:47 AM   #3
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,871

Rep: Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169Reputation: 2169
How did you install the HP printer? If you used hp-setup, that would have configured Xsane and it might the the problem. I remember it once prevented my Cannon scanner from working. You could try (1) uninstalling both devices, (2) re-installing the scanner with the printer disconnected, and (3) re-innstalling the printer.

It could be worse: I once had a distro mistake my USB speakers for a keyboard and so ignore the real one!

Last edited by DavidMcCann; 06-28-2016 at 11:53 AM. Reason: Improvement
 
Old 06-28-2016, 01:17 PM   #4
borgward
Member
 
Registered: Apr 2005
Location: Austin, Texas
Distribution: Feather, Darn Small Linux
Posts: 381

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by DavidMcCann View Post
How did you install the HP printer?
I am running Linuxmint MATE 17.3 I did not do anything to install the scanner. I used Menu > Administration > Printers to install the printer. The scanner is SCSI or parallel, but xsane does not support the parallel connection, so it is connected scsi.


Quote:
Originally Posted by DavidMcCann View Post
If you used hp-setup, that would have configured Xsane and it might the the problem.
The printer was installed before I installed xsane. What is hp-setup? Something different than Menu > Administration > Printers to install the printer?


Quote:
Originally Posted by DavidMcCann View Post
You could try (1) uninstalling both devices, (2) re-installing the scanner with the printer disconnected, and (3) re-innstalling the printer.
Did that. Same result.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Printer Scanner in Xsane finds new printer/scanner (Brother MFC-6520DW) with error message TrinityBeing Linux - Newbie 23 03-29-2016 11:27 AM
[SOLVED] Fedora 18 x64, xsane won't detect scanner even though sane-find-scanner does SharpyWarpy Linux - Hardware 8 03-17-2013 07:18 PM
Scanner/Printer Combo Unit - Scanner Works - Printer Does Not rrrssssss Linux - Hardware 1 03-04-2007 11:49 PM
scanner with xsane rksprst Mandriva 3 02-10-2005 06:23 PM
Xsane and scanner mdk Mandriva 0 09-21-2004 03:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration