-   Linux - Software (
-   -   XP wants to enter recovery mode after installing RH9 (

luizebs 12-24-2004 01:20 AM

XP wants to enter recovery mode after installing RH9
Dear Linuxers,
I just installed RH9 on a new HD, and would like to have XP on the original HD (for my wife). Everything was fine with the installation and I was able to boot to RH and to windows XP. I installed Lilo on the MBR.
The problem is that when I boot to WindowsXP, it enters in a recovery mode, and if I accept the recovery process, it will screw up my boot. (I once tried, and I couldnt boot at all - I had to boot Knoppix from CD to alter GRUB (that time I opted for GRUB instead of LILO), at least to check if I have lost any data... Everything was fine...). Then after spending a lot of time trying to fix boot loaders, I went for a new linux installation (RedHat installed again in the same place). This time I opted for LILO.

Now I have dual boot again, but still, when I go to Windows, it enters in the damn recovery mode, which I am afraid will screw up everything (i mean Boot) again...

I tried to skip this recovery mode, but there is no way: next time I boot, windows ask me again to run recovery...

Can anyone help me?

zatka 12-24-2004 01:48 AM

ur biggest mistake....................
u installed lilo on MBR. it should be installed on /boot parttion.

Follow the link,

create a boot floppy wen prompted to do so in installation procedure.

luizebs 12-24-2004 02:04 AM

No floppy
There is no floppy in my desktop...
How can I go back and revert this?
If I reinstall Linux, MBR will still be wrong... right?

Hangdog42 12-24-2004 08:31 AM

First off, installing LILO to the MBR is NOT a mistake, it is a perfectly viable option. You probably want to post at least the windows section of your /etc/lilo.conf file. For comparison, here is mine, and I dual boot from the MBR without any problems:


# Windows Boot Section
other = /dev/hdc2
  label = WindowsXP
  table = /dev/hdc
#End of Windows boot section
#Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hdc6
  label = Linux
  append = "acpi=on"

Of course your disk designations will be different.

zatka 12-24-2004 09:10 AM

if u dont have a floppy there's workaround.
boot from 1st linux cd-rom, at the boot prompt type linux rescue or rescue (i gues). u wil get a prompt. there mount ur windows partition in /mnt if it is not already mounted.
then issue this comman

dd if=/dev/hda3 of=/bootsect.lnx bs=512 count=1

after this copy the bootsect.lnx file to ur windows partition.
edit boot.ini after booting in windows. and add entry


here c:\ is the location where u hav copied bootsect.lnx

i hope this clears all stuff.

zatka 12-24-2004 09:18 AM

i forgot to mention,
/dev/hda3 in the dd command is the boot partition.

if u want to see ur /boot partition issue this command,

df -h

u wil get a list of partitions on ur HDD.
replace /dev/hda3 with the respective /boot partition.

luizebs 12-24-2004 02:31 PM

Sure, my lilo.conf looks like this:


append="hdc=ide-scsi root=LABEL=/"


(Forgive me, I am quite ignorant in these boot issues, I just learn a little bit with this problem...)

Marry Christmas to all,

luizebs 12-24-2004 02:53 PM

Do you think it is really a boot issue? I mean, XP is booting... The only problem is that he somehow recognize some unexpected alteration and "instists" in running recovery...
I am very confused...

Hangdog42 12-29-2004 08:55 AM

I think the lack of a "table" directive in your Windows section could be causing trouble. I'm not sure that Windows is getting all the info it needs from LILO to boot properly and that may be causing it to think something has gone wrong. So yes, I do think it is a boot issue. I would try modifying your lilo.conf to match mine (only keep your disk settings) and see what that gets you.

All times are GMT -5. The time now is 07:06 PM.