LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 12-01-2011, 09:45 PM   #1
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Rep: Reputation: 0
Xorg -configure SegFaults


I've got a Lenovo G575 laptop that I installed Debian Squeeze (stable) on. I tried to generate an xorg.conf with Xorg -configure and got a segfault. Here's a copy of Xorg.0.log.old that has the error at the end. http://pastebin.com/MMvsZkvu

I don't know how relevant this is, but I needed an xorg.conf so I could change the video driver. Usually you'd use `aticonfig --initial`, but it couldn't find my graphics card. I've got a Radeon HD6320 thats integrated in the AMD Fusion E-450 processor. Debian doesn't normally use an xorg.conf, instead Xorg detects your hardware when it starts. I'm going to make a thread for that in the hardware section, I'll link to it once I do in case these problems are more related than I think.
 
Old 12-02-2011, 07:37 AM   #2
RudyMartin
LQ Newbie
 
Registered: Nov 2011
Location: Argentina
Distribution: Slackware
Posts: 25

Rep: Reputation: Disabled
at 303: (++) Using config file: "/root/xorg.conf.new"

have you tried to move/remove xorg.conf.new ?

also, since you don't have /dev/fb0, could it be a module blacklisted on /etc/modprobe ?
 
Old 12-02-2011, 07:48 AM   #3
cstn
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Rep: Reputation: 0
my laptop with HD3650 also installed Debian Squeeze, using fglrx (ccc version 11.11) driver. it seems some problems of displaying when the system recovers from suspending to memory or disk, LCD display nothing even without backing-light ,ctrl+alt+F1 switch to tty1 console,system can receive bash-shell orders like reboot\halt 0 and so on. sometimes LCD display nothing but backing-light, at this situation, switching to tty1 is normal, LCD display words, then execute "service gdm3 restart" as root, the gnome shell will restart normally with fglrx driver.

i tried to mv etc/X11/xorg.conf to xorg.conf.bkp, it means i let the x-window starting without the xorg.conf file, and the system suspends to mem or disk normally, even the system recovers at any time,but x-window can not using fglrx driver to actualize the 3D acceleraion.

so i modified the xorg.conf file, as this:
Code:
#Section "ServerLayout"
#	Identifier     "aticonfig Layout"
#	Screen      0  "aticonfig-Screen[0]-0" 0 0
#EndSection

#Section "Module"
#EndSection

#Section "Monitor"
#	Identifier   "aticonfig-Monitor[0]-0"
#	Option	    "VendorName" "ATI Proprietary Driver"
#	Option	    "ModelName" "Generic Autodetecting Monitor"
#	Option	    "DPMS" "true"
#EndSection

#Section "Monitor"
#	Identifier   "0-LVDS"
#	Option	    "VendorName" "ATI Proprietary Driver"
#	Option	    "ModelName" "Generic Autodetecting Monitor"
#	Option	    "DPMS" "true"
#	Option	    "PreferredMode" "1280x800"
#	Option	    "TargetRefresh" "61"
#	Option	    "Position" "0 0"
#	Option	    "Rotate" "normal"
#	Option	    "Disable" "false"
#EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "Monitor-LVDS" "0-LVDS"
	BusID       "PCI:1:0:0"
EndSection

#Section "Screen"
#	Identifier "aticonfig-Screen[0]-0"
#	Device     "aticonfig-Device[0]-0"
#	DefaultDepth     24
#	SubSection "Display"
#		Viewport   0 0
#		Depth     24
#	EndSubSection
#EndSection
the probability of happening displaying problem is rare when system recovers from mem or disk. but sometimes it happened still. up to now,i
have no idea with this.

(ps: my laptop had a nvidia 8600m gt graphic card before, debian squeeze with nvidia private driver worked well on suspending to mem or disk, saddly my 8600m gt trapped in the nvidia's graphic card gate, so i used a HD3650 to instead of 8600m gt, then my laptop's problem pops up)
 
Old 12-02-2011, 08:26 PM   #4
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
Xserver-xorg is very good at setting up options, elaborate xorg.conf files are more likely to be unstable as of late. I built a Debian Live USB a few months ago, tested it in hundreds of demo laptops and desktops at major computer vendors to get it working nice on any machine. Below is the ATI xorg.conf file that works best:
Code:
Section "Device"
    Identifier  "ATI"
    Driver      "fglrx"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection
 
1 members found this post helpful.
Old 12-02-2011, 11:21 PM   #5
cstn
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by Brains View Post
Xserver-xorg is very good at setting up options, elaborate xorg.conf files are more likely to be unstable as of late. I built a Debian Live USB a few months ago, tested it in hundreds of demo laptops and desktops at major computer vendors to get it working nice on any machine. Below is the ATI xorg.conf file that works best:
Code:
Section "Device"
    Identifier  "ATI"
    Driver      "fglrx"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection
thank you so much, you did a great job! that's very helpful for the newbies of linuxer, like me. i'll try your code
 
Old 12-04-2011, 09:42 PM   #6
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by RudyMartin View Post
at 303: (++) Using config file: "/root/xorg.conf.new"

have you tried to move/remove xorg.conf.new ?

also, since you don't have /dev/fb0, could it be a module blacklisted on /etc/modprobe ?
I removed the xorg.conf.new and it failed at the same place, after generating an identical xorg.conf.new. That old one must have been from another failed Xorg -configure attempt, and I've been getting the same error every time. /etc/modprobe doesn't exist.

I just copied the xorg.conf that Brains posted, I'm going to restart gdm after I post this.
 
Old 12-04-2011, 11:09 PM   #7
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
I tried Brains' xorg.conf, after replacing fglrx with radeon because I don't have fglrx installed. When I tried the radeon driver, I got a black screen with an underscore cursor that displayed everything I typed. I also tried the radeonhd driver, but I got the same black screen with a cursor blinking a lot faster and didn't respond to any key presses, even alt+ctrl+F1. The same thing happened when I tried the xorg.conf.new file Xorg -configure made before segfaulting. Here's the log from trying the radeon driver: http://pastebin.com/EbfLxV0V

Last edited by kauaianspunger; 12-04-2011 at 11:53 PM.
 
Old 12-05-2011, 01:05 AM   #8
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
The xorg.conf file should be in /etc/X11 not /root, no need to have the word "new" attached.

According to Debian packages web site search, the current fglrx-driver package version for Debian stable is # 10-9-3. The version my Debian live testing I made last year is # 11-3-1 which will not work for that graphics card device ID of yours ---->1002:9806, I recently tried it on a newer laptop at a computer vendor with device ID 1002:9647 which is not supported by fglrx-driver-11-3-1, xserver-xorg didn't even load the radeon driver, it used vesa on that machine.

The current version for Debian testing is # 11-11-3, I downloaded it, took it apart to look at the amdpcsdb.default file which is usually found in /etc/ati, you can see if your card is supported by checking to see if the device ID is in that file with this command: grep -n 1002-9806 /etc/ati/amdpcsdb.default, the -n will show the line number of the file where the device ID was found.

You may need to modify your /etc/apt/sources.list to include a Debian testing non-free mirror, do an update, then install fglrx-driver-11-11-3 if you are currently using the version from Debian stable mirrors. cstn should be able to guide you in that regard.

After installing fglrx from testing, comment out the line for testing in the /etc/apt/sources.list and redo an update to keep your installation stable, otherwise things might get bloated and screwy.

Last edited by Brains; 12-05-2011 at 01:15 AM. Reason: added advice
 
Old 12-05-2011, 02:22 AM   #9
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
xorg.conf.new is what 'Xorg -configure' generates, and I was in /root when I did it. When I tried what you posted before, I put it in /etc/X11/xorg.conf. I'd rather avoid using packages from testing if I can, but I switched to the testing repos and got some errors:
Code:
$ sudo apt-get install fglrx-glx
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8 is to be installed
E: Broken packages


$ sudo apt-get install gcc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-0 : Breaks: gnome-control-center (< 1:3) but 1:2.30.1-2 is to be installed
 network-manager : Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is to be installed
E: Broken packages
I might try to install Debian Testing, which is actually what I want to use. I used unetbootin to make a bootable usb and selected Debian Testing but it installed Squeeze. I tried changing /etc/apt/sources.list to testing but apt-get upgrade failed and I had to reinstall Squeeze. I think the standard way of installing debian testing failed too, but I'm going to try again.

edit: now I remember, the installer for testing doesnt have drivers for my ethernet card. I'm going to see if I can find firmware for it that works with the installer, hopefully once I install it my video card will work.

Last edited by kauaianspunger; 12-05-2011 at 03:37 AM.
 
Old 12-05-2011, 03:32 AM   #10
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
Google key words "Debian installer" to take you to testing download/installation stuff.
 
Old 12-05-2011, 03:41 AM   #11
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
I didn't see your post before I edited mine... The new debian installer doesnt have firmware for my ethernet and wireless cards, but I just found them.

Thanks for all the help so far, by the way.
 
Old 12-05-2011, 05:53 AM   #12
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
I got testing installed, after a few tries at getting the firmware recognized I realized it was asking for firmware for the wireless card. Ethernet usually works for a while, long enough to install debian and get the wireless drivers.

Testing won't boot all the way, though. It gives really bad artifacts, like colorful static. When I do a normal boot I can see a box behind the static where the mouse arrow would be and it responds to input. There's a 'recovery' item in the GRUB menu that gives you a chance to log in as root before switching to the final runlevel where GDM and X are run. I get the static before X is supposed to start, and I never pressed ctrl+D to skip logging in as root to do system maintenance. I'm back in Squeeze again so I can get any log files that might be relevant. I didn't see any errors in the Xorg log file, but I get artifacts when X never starts, anyway.
 
Old 12-05-2011, 03:05 PM   #13
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
You can get it done from command line by booting in recovery mode. Here's how assuming you have an internet connection via the NIC, you might want to print these instructions:
Here is how your entry for /etc/apt/sources.list needs to look like:
Quote:
deb http://ftp.us.debian.org/debian wheezy main contrib non-free
Put the xorg.conf file I posted on a USB key. Boot into recovery mode and enter your root password. Now, you need to edit the /etc/apt/sources.list to include non-free for installing fglrx. To do so, enter command: vi /etc/apt/sources.list, you will now be in vi editor mode and the only thing on the screen should be the sources.list file. Use down arrow key to bring the cursor down to the debian mirror line, use right arrow key to bring the cursor to the end of the line, hit the "i" key to insert, type the last letter you see in that line, for example, if the last word is "contrib" type the letter "b", now hit the space bar once and type without quotes "non-free", now hit excape key, move the cursor to the right so it is on the last letter that was carried over, like the "b" from contrib and hit the "x" key to remove it.
You should do this for the security line also, but not needed at this point, you can choose to do it now or after you get a GUI desktop. Once the line(s) have the non-free added and you've hit escape and removed extra letter(s), hit the shift and semi colon : keys at the same time, a semi colon should appear at the bottom of the screen, now type without quotes "wq!" and hit enter to write an quit.
Now you should be back at the prompt, run command: aptitude keep-all, and when the prompt comes back enter this command: aptitude update to update the list of available packages. From now on, you are best to use aptitude from command line instead of apt-get, but it is not imperative.
When the prompt returns, enter this command to see which kernel package is installed: dpkg --get-selections | grep linux-image. Using this example return---->linux-image-3.1.0-1-amd64, the next command will be to install fglrx and kernel headers to compile the module as well as all dependencies, the word "image" in the output of the --get-selections command needs to be replaced with the word "headers", make sure to use your actual kernel, not mine in this example if it is different: aptitude -r install linux-headers-3.1.0-1-amd64 fglrx-control fglrx-driver.
If the prompt comes back without error, now you need to put the xorg.conf file in place.
Insert the USB key and wait for a few lines of text to flash by then hit the enter key to get the prompt back and type: fdisk -l, a list of drives should appear, if your key is /dev/sdb and only has one partition /dev/sdb1, mount the key with this command: mount /dev/sdb1 /mnt. Now copy the xorg.conf file to /etc/X11 with this command: cp /mnt/xorg.conf /etc/X11/.
Reboot with this command: reboot, select normal boot and log in as your user.

Last edited by Brains; 12-05-2011 at 03:07 PM. Reason: Took happy face out
 
Old 12-06-2011, 12:24 AM   #14
kauaianspunger
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Stable
Posts: 22

Original Poster
Rep: Reputation: 0
I get artifacts even when I boot into recovery mode, before it's supposed to prompt for the root password, right after loading initrd.

Quote:
Originally Posted by Brains View Post
Reboot with this command: reboot, select normal boot and log in as your user.
I not sure this is necessary, you can press ctrl-D at any time to exit maintenance mode and continue booting. Also, nano is installed by default on Debian, I was surprised to find they don't even include vi/vim in the installer.

Last edited by kauaianspunger; 12-06-2011 at 12:29 AM.
 
Old 12-06-2011, 01:48 PM   #15
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
I have found over time, it is a time saver to just reboot as many configurations do not take effect until a reboot, like the firmware-linux-nonfree package required to be installed after enabling non-free in your sources.list in order to have wireless networking.
Debian used to pride itself in the fact that the only time you needed a reboot was after a kernel upgrade. But they've gone "free, all free," now which means proprietary stuff like fglrx and firmware are not part of the official distribution.
The Debian CD search will show vim-tiny is included in the daily-builds (Daily small CD builds).

What exactly do you mean by "I get artifacts".
EDIT: You can hit the "e" key at the grub menu, edit the long line starting with "linux /boot/vmlinuz" and ending with quiet or single. Use backspace key to remove quiet and ro, then add "single" and "vga=xxx" to use vesa driver. The xxx needs to be replaced with a number matching one of the video modes your laptop uses, a guide to the different modes here. For instance, to use 1280x1024 24-bit it would be vga=795. And for all intensive purposes, video is controlled either by an add-on video card or on the chip which is part of the motherboard, not controlled by the E-450 processor, The specs for the Lenovo G575 specify AMD Dual-core E-350 1.6GHz

Last edited by Brains; 12-06-2011 at 02:28 PM. Reason: Added boot parameter option
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware64 13.37 KVM GUEST Xorg segfaults when starting KDE (workaround) rtguille Slackware 2 05-15-2011 05:13 PM
[SOLVED] xorg segfaults with nvidia driver after upgrade to 13.1 htitan Slackware 4 06-06-2010 02:28 PM
[SOLVED] Xorg 1.6.5: can't find the xorg.conf file to configure keyboard. dreamwalking Linux - Newbie 16 12-19-2009 08:24 AM
Xorg, Xorg -configure fail kupek85 Linux - Software 3 08-05-2004 08:09 PM
Configure xorg iotc247 Slackware 1 05-30-2004 01:39 PM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration