LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   xmodmap file is not loaded by .xinitrc (https://www.linuxquestions.org/questions/linux-software-2/xmodmap-file-is-not-loaded-by-xinitrc-4175594601/)

Cág 12-01-2016 01:56 PM

xmodmap file is not loaded by .xinitrc
 
Hi,

I have been loading xmodmap file with xmodmap .Xmodmap in my .xinitrc for some time now to fix brightness keys. Now I found out that it is no longer loaded (brightness keys don't work), unless executed manually. Has someone had it?

I've surfed the web only to find out some relatively old bug reports from Ubuntu and Fedora solved by those weird GNOME settings. What's interesting, xmodmap -e "pointer = 3 2 1" - right mouse button becomes primary - works from the same .xinitrc.

Setting those keys with xmodmap -e ... doesn't work too.

My system is Alpine with dwm.

BW-userx 12-02-2016 07:55 PM

Quote:

Originally Posted by Cág (Post 5636775)
Hi,

I have been loading xmodmap file with xmodmap .Xmodmap in my .xinitrc for some time now to fix brightness keys. Now I found out that it is no longer loaded (brightness keys don't work), unless executed manually. Has someone had it?

I've surfed the web only to find out some relatively old bug reports from Ubuntu and Fedora solved by those weird GNOME settings. What's interesting, xmodmap -e "pointer = 3 2 1" - right mouse button becomes primary - works from the same .xinitrc.

Setting those keys with xmodmap -e ... doesn't work too.

My system is Alpine with dwm.

DWM -- try adding the keyboad shortcuts in your file then make clean - reload dwm


https://bbs.archlinux.org/viewtopic.php?id=204791

Cág 12-03-2016 02:40 AM

Quote:

Originally Posted by BW-userx (Post 5637265)
DWM -- try adding the keyboad shortcuts in your file then make clean - reload dwm


https://bbs.archlinux.org/viewtopic.php?id=204791

Done that already in the previous thread. These keys are working when manually running xmodmap .Xmodmap with X11 loaded, the line simply stopped being loaded from .xinitrc for some reason.

ondoho 12-03-2016 05:20 AM

show us the output from the failed attempts, with -verbose switch.
show us the exact line in ~/.xinitrc, or better the whole file.

Cág 12-03-2016 06:30 AM

I found the problem. I recently played with keyboard layouts and added the line with setxkbmap -layout... after xmodmap .Xmodmap like this:
Code:

xmodmap .Xmodmap
setxkbmap -layout...

thus turning the custom mapping off. So I put xmodmap .Xmodmap after setxkbmap... like this
Code:

setxkbmap -layout...
xmodmap .Xmodmap

and it worked. Thanks for the suggestions.


All times are GMT -5. The time now is 11:55 AM.