-   Linux - Software (
-   -   XMMS - Streaming via Samba? (

Idle 12-31-2004 08:37 AM

XMMS - Streaming via Samba?

I have two computers connected by a crossover cable. One is a Windows 2000 box, and the other is Slackware 10.0 (kernel 2.6.10). I've just compiled and installed Samba 3.0.10, and am able to access shared directories on the Windows box in Konqueror (different problem, but is there a way to make Firefox recognise the SMB protocol?). Now, I have some music on my Win box I'd like to play in XMMS, but so far the only method that has worked for me is to enqueue individual files (definitely tedious and annoying if one's got lots of music).

I've tried the whole drag'n'drop shebang, adding files by URL, et cetera in XMMS, but without luck. There has to be some way, righ'? :confused:

Mind you, I'm relatively new to Linux, so don't get too advanced on me. :)

acid_kewpie 12-31-2004 08:47 AM

firefox doesn't, and will never, recognise smb protocols. firefox is a very focused web browser, and so has nothing at all to do with lan shares.

why not just mount the thing as a local drive??

mount -t smbfs //windows/share /mnt/windows_share

Idle 12-31-2004 09:09 AM

That's what I was hoping I could do. Now, I just tried that, but clearly I must be doing something wrong.

root@armageddon:~# mount -t smbfs //athena/G$ /mnt/athena_g
Could not resolve mount point /mnt/athena_g

The Windows box is called "athena" and the share name is "G$". Illegal characters somewhere, perhaps?

Edit: Never mind... Got it working. Just had to read a bit more.
Thanks! :)

Zyrix 12-31-2004 10:13 AM

What was the solution? Had to change the computername to IP address or add that to hosts file?

acid_kewpie 12-31-2004 10:32 AM

/mnt/athena_g presumably did not already exist as a directory. it needs to be there as an empty directory in order to be used.

Zyrix 12-31-2004 11:12 AM

Ahhh, gotcha.... gonna give that a try when i get home. Thanks!

Idle 12-31-2004 03:14 PM

Aye, I forgot to create the directory I was attempting to mount it to. Isn't it just wonderful how easy it is to overlook something as simple? :rolleyes:

Also, I didn't know why it didn't work at first after adding it to fstab, but of course that was equally simple. I forgot to throw in the user name and password (i. e. "//computer/share /someplace smbfs dmask=777,fmask=777,username=HellNo,password=ForgetIt 1 0"). :rolleyes:

All times are GMT -5. The time now is 12:26 AM.