LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   xmms, RedHat9, CM8738, MP3's won't play (https://www.linuxquestions.org/questions/linux-software-2/xmms-redhat9-cm8738-mp3s-wont-play-69152/)

niverson 06-30-2003 07:53 PM

xmms, RedHat9, CM8738, MP3's won't play
 
My motherboard has the CM8738 chipset on it. I just installed RedHat 9, I was running Windows 2000 before that---I'm new to linux. I can play CD's through the CM8738, but XMMS doesn't play MP3s. What do I need to do to play MP3's under Linux? I did a some searching on google for other MP3 players, but nothing has worked so far.

Thanks,
Nate

dlausevic 06-30-2003 07:56 PM

Redhat, by default, doesn't support mp3s. You have to go to xmms's site and download a small patch to make it run. They do it to prevent copyright crap. While we're at it, DMA is also disabled for the DVD aspect too. You may want to read the release notes for RH9. IT will explain how to reenable DMA.

praveen_2003 06-30-2003 11:05 PM

did u download plugin for that stuff?

niverson 07-01-2003 12:22 AM

Thanks for the responses.

I downloaded and installed the following RPM from xmms.org-----xmms-mpg123-1.2.7-21.i386.rpm

but, It doesn't seem to complete the installion----so I'm not sure what to do next.

Nate

dlausevic 07-01-2003 03:51 AM

Quote:

Originally posted by niverson
Thanks for the responses.

I downloaded and installed the following RPM from xmms.org-----xmms-mpg123-1.2.7-21.i386.rpm

but, It doesn't seem to complete the installion----so I'm not sure what to do next.

Nate

Try logging in as superuser and installing the rpm then.

niverson 07-01-2003 08:20 AM

RedHat 9 automatically prompts you for root's password to do the rpm install, so I'm assuming that action was promoted to superuser access.

Any other ideas?

Nate

jchristman 07-01-2003 08:27 AM

If the rpm does not seem to finish, check the rpm to make sure it is not corrupt, or download it again. Will xmms play other music files, if not them remove it and reistall xmms.

niverson 07-01-2003 08:56 PM

I'm a bone head. I didn't configure the output to be OSS, it was esound.

Thanks for all the help.

Nate

giang 07-09-2003 03:02 PM

Can you tell me how you did that?
I had redhat 9 but it doesn't play cd or mp3 at all.
However, it still play other system sounds in Linux

Jose Muņiz 07-09-2003 03:04 PM

giang... did you install the xmms-mpg123-1.2.7-21.i386.rpm package, too?

niverson 07-09-2003 11:06 PM

Open XMMS. Right click on the XMMS and select Options->preferences. Select OSS Driver from the Outout Plugin drop down box.

You still need to install the mpg123 plugin that was mention in the previous posts.

Nate

niverson 07-09-2003 11:11 PM

I also have to run the sound card detection (redhat icon ->System Settings->Soundcard detection) everytime I boot up. I need to build a new kernel with cmpci support. I think I had a resource conflict between the CM8738 and my NIC when I installed RH9. When I first installed RH9, the NIC was not found. I went into the motherboards BIOS and changed the OS type from Plug and Play to non-Plug and Play ---- magically RH9 found the NIC.

giang 07-10-2003 01:39 PM

Thanks, I got xmms to play mp3 after installing the plugin. However, I still cannot play music from cd because I could not mount it. Well, I'll try to figure it out eventually. Thanks a lot.

InSane103 07-10-2003 10:15 PM

Mandrake 9.1, no updates, or anything can play mp3 files out of the box (through xmms) but not mpeg.

jchristman 07-11-2003 07:48 AM


giang,


Linux does not mount audio cd's like a data cd.
To listen to audio cd's with xmms put the cd in the player
then start xmms. No click on the addfile button and tell it to add the dir of the cd. like /mnt/cdrom this will load all the tracks off of the cd.
CD Audio Track 01
CD Audio Track 02

you will see them as Track 01.cda, Track 02.cda

all audio cd players in linux work the same way you do not mount the cdrom to listen to the cd.

I hope this was helpful.

Jason


All times are GMT -5. The time now is 12:16 PM.