LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-04-2003, 01:53 AM   #16
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30

How to do all that,,
I go to sessions from the menu and disable startup thig because I used to work it all the time,
Now it's off,
How to do that oss thing ?
I tried to change it from xmms, Still not working .
No sound comes out .
What to do ?
 
Old 10-04-2003, 06:09 PM   #17
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
when you login to kde, is arts actually running?
You can check by
artsshell status
in a terminal. Maybe it does not start at login and that's why you need to starts artscontrol (which will force the arts to start as well).
 
Old 10-04-2003, 09:34 PM   #18
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
Ok....so you can start aRts using 2 ways:

1. On the console, type

artsd -help

This will show you a list of options that you can use with this command.
The option that looks good for you is

artsd -a <audioiomethod>

( The -a option specifies what sound system you want to use with aRts...like OSS, or ALSA..etc)

However, check what other options are relavent in your case from the list. that appears in help

2. You can enable aRts to start at the time of system startup too.

go to Preferences - > Sound

and check the box before
"Enable sound server startup"

The second step is valid only for RedHat 9.....In Mandrake, you can check this box from the "Control Center"

However, I would like to tell you something more....

I dont think you need aRts....If there is no sound....then you need to do the following things:

(a) First load the module for your sound card with the command

modprobe <your-sound-card-model-name>

example modprobe opl3sa2
(I have the yamaha Opl3 sa3 sound card)

(b) now give the command

sndconfig

Configure the DMA settings and IRQ for your sound card with this command. If you dont know the DMA and IRQ settings, check the settings in MS Windows....if you have a dual boot.....

In windows you will find these settings as follows:

Right Click My Computer -> Propeties -> Device Manager -> Sound, Video and Game Controllers -> Select your sound card model and click the 'Properties' button. That will display the DMA and IRQ settings for your soundcard.

It will then play a test sound....which you should be able to hear, provided, the sound module is loaded in memory.

If the above 2 steps work for you, then you need to place the " modprobe <your-sound-card-model-name> " command in the file /etc/modules.conf script to initialize sound at startup.

Regards,

amit
 
Old 10-06-2003, 12:34 AM   #19
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
How to get the sound card model name,,(From where)

Here's what I've got from Windose,,,,

IRQ = 17
I/O Range = 1200-12FF
I/O Range = 1300-133F

______________________________

About the model:

Intel(r) 82801AA AC'97 Audio

About the module from the redhat soundcard detection :

i810_audio

____________________________

I couldn't find anything else that I thought it would help us in solving this problem .

What to do then ?

!!!

Last edited by Anmar; 10-06-2003 at 12:39 AM.
 
Old 11-09-2003, 08:02 AM   #20
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
I still need help,
What to do Please?
 
Old 11-09-2003, 08:24 AM   #21
shinwise
LQ Newbie
 
Registered: Oct 2003
Location: Okazaki, Japan
Distribution: Mepis
Posts: 27

Rep: Reputation: 15
looks like you have an on-board standard AC 97 compatible Intel_810. I think I saw this same problem before back when I was running Redhat8, I shut down while XMMS was still running and when I started back up XMMS sound was all hosed up, think what I did in the end was uninstall XMMS and re-install it again and that fixed the problem.

This was almost a year ago so I can`t remember for sure and I don`t run Redhat anymore cause I mostly switched to Debian based distro`s now.

Last edited by shinwise; 11-09-2003 at 08:26 AM.
 
Old 11-12-2003, 07:13 PM   #22
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
WOW,,It's working,

Thanks alot dude,,,

But it caused an other problem,,,

Before I reinstall I was able to play audio cds in xmms,,,,(Had installed some plugin for that)

Now I can't install the plugin again,It works ok til I "make install" then it stops,

It doesn't install the plugin successfully,

What to do ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable sound on both xine and xmms in the same time? johnnydangerous Fedora 3 02-04-2005 01:22 AM
XMMS skipping and stopping under 100% cpu time (*not load) guardian653 Linux - Software 3 10-26-2004 07:16 PM
AC97 works with ALSA - how can two programs use it at the same time? (XMMS + a game) SBing Linux - Software 2 07-18-2004 06:45 AM
XMMS BZFLAG at same time how? Outabux Debian 4 04-28-2004 04:33 PM
Running Kaffeine and XMMS at same time ghight Linux - Software 1 04-15-2004 03:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration