Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-06-2004, 04:28 PM   #1
Registered: Jan 2004
Location: USA, Pa
Distribution: Slackware 10
Posts: 65

Rep: Reputation: 15
Question XMMS glib-config error (old conflicting version maybe?)

Hello (the following was all done through console: )
I know it shouldn't be hard, but i have had a tough time installing this program. First I attempted to download and install the required libraries. This was done by untar'ing them then typing ./configure while inside the newly made directory. (IF THIS IS THE INCORRECT WAY PLEASE TELL ME). Once I did that to all the required ones stated by the documentation I went and did the same thing to the actual xmms file (untar'ed then ./configure). But this following error shows up:

checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

I understand (i think) what it's asking me for, It doesn't want the old 1.2.1 glib on my system. It tells me how to fix this error but I dont know what "LD_LIBRARY_PATH" or "/ect/" is (google was no help either).

Inside the "/usr/local/bin/" directory is the file "glib-config" (like it said 1st line) but i think that just states what version it is. Does anyone know how for me to completely get rid of glib so i can reinstall it?


-also if anyone wants to explain what ./configure does that will be helpful too. I've been told by websites to do it, not explaining what it does. Also what about "make" and "make install"?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
XMMS ./config GLIB >= 1.2.2 not installed error clonedmessiah Linux - Newbie 2 10-06-2006 01:23 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
xmms glib pointer error / flac solution Bluesuperman Slackware 0 05-22-2005 01:19 PM
Installing XMMS Error with glib Egan Linux - Software 4 12-21-2004 10:31 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:34 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration