LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-14-2004, 02:29 PM   #1
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Rep: Reputation: 31
XMMS error


Trying to start XMMS results in:

ebian:~# xmms
libmikmod.so.2: cannot open shared object file: Onbekend bestand of map
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
debian:~#


Not a clue where to start fixing this........
Any Help?

Regards
 
Old 05-14-2004, 02:51 PM   #2
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Rep: Reputation: 30
Hi powadha,
the first error means that the file "libmikmod.so.2" could not be found (that error is dutch, isnt it?). This is probably due to the fact that it isnt there
Reinstalling xmms should suffice to fix this issue. (as root run apt-get install xmms --reinstall, if I am not mistaken. I dont have a debian system here.)
The second error sound trickier, but with some luck it will go away, when you fix the first error.

On a sidenote: it is easier for us english (non-native, yes ) speaking folks, if you reproduce the error with a standard locale setting (export LOCALE=C).

Good luck,
- drowstar
 
Old 05-14-2004, 03:14 PM   #3
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Original Poster
Rep: Reputation: 31
Thanx for trying to help me out. I tried your solution and your command for apt-get was right. XMMS installs nicely but I'm afraid the error is still the same when trying to run xmms.
btw, error is in dutch I overlooked that part. That part of the erroris: unknown file or dir.
For your information: running Deb SID with no futher errors or problems (known anyway)

(Dutch it is, although my mom is 100% Irish, she would punish me if she would ever read my bad English in here )
 
Old 05-14-2004, 03:52 PM   #4
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Rep: Reputation: 30
Hi powadha,
hm, too bad it didnt work.
OK, lets try something different then.

Maybe the file is there, but cant be found:

1) Finding that f*** file:
find / -iname libmikmod.so* -maxdepth 3 -mount
(you can also use the following, if you have an up-to-date slocate database (if you dont know what the heck this is, you dont), try locate libmikmod.so.)
1.1) See, if this returns an exact match (if it contains libmikmod.so.2).
(If it returns something that has more than 2 at the end (e.g. libmikmod.so.2.0.4 would also count), try symlinking that to libmikmod.so.2 (e.g.:ln -s /usr/lib/libmikmod.so.2.0.4 /usr/lib/libmikmod.so.2). Maybe this already was it, try it now, if you made a link).
1.2)If there was an exact match, check, if the directory that contains libmikmod.so.2 is in your path (echo $PATH). If it is not, try setting the PATH to contain it (e.g. export PATH=$PATH:/usr/lib). If it works now, you need to make the path-change permanent. Post back in this case, this could get messy .

2) Installing the library
If 1 did not return a file, it is probably not there. (If you want to make really sure, try re-scanning your entire system for the file with this command: find / -iname libmikmod.so*). The solution to this is to install libmikmod (some sound library, from what I have been able to learn). Download an appropriate file from this mirror (in the Netherlands ) and install it.
Check, if the error is still there.

Good luck. If none of that worked, post back to this thread, please,
- drowstar
 
Old 05-15-2004, 10:41 AM   #5
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Original Poster
Rep: Reputation: 31
Hi drowstar,

find / -iname libmikmod.so* -maxdepth 3 -mount
Works but starting xmms results in the same error.

locate libmikmod.so

results in (I use slackware as second os):

/mnt/slack/usr/lib/libmikmod.so
/mnt/slack/usr/lib/libmikmod.so.2
/mnt/slack/usr/lib/libmikmod.so.2.0.4
/mnt/slack/usr/lib/xmms/Input/libmikmod.so
/usr/lib/xmms/Input/libmikmod.so

On deb only one file is found.......

So the lib is there but so is the error. I hope you have another idea to try.

Thanx!
 
Old 05-15-2004, 10:52 AM   #6
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Original Poster
Rep: Reputation: 31
Tried installing the lib just to be sure and: it works! Thanx a lot!
 
Old 05-18-2004, 12:13 PM   #7
sBlatt
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
apt-get install libmikmod2

worked fine for me =)

but thx anyway
 
Old 05-26-2004, 02:28 AM   #8
yakuzay
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
thx

an apt-get install libmikmod2 worked fine for me :-)

thx
 
Old 05-26-2004, 07:04 PM   #9
JO_D_T
LQ Newbie
 
Registered: Apr 2004
Location: Castelldefels
Distribution: FC1
Posts: 1

Rep: Reputation: 0
Talking XMMS (Incorrect Operation) in Fedora Core 2

Hi, I've recently installed Fedora Core 2 and i could see that my XMMS crashes suddenly without any error notice. Y tried to update to older version

but the problem success too, and cannot be from any library of mp3, because I installed a plug-in which uses the Radio Receiver which have my

TV-card and crashes too, i probed to execute from a Xterm and i could see a very small message... "Incorrect Operation"

Someone had any problem like me?


------------------------
Thanks and sorry for my poor English...
 
Old 05-27-2004, 06:22 AM   #10
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Rep: Reputation: 30
Hi JO_D_T,
are you aware that FC does not come with the ability to play mp3? (Stupid Redhat policy, dont bother, rh just is like that)
May not be related at all. Try installing the appropriate rpms and see, if the error goes away.

Also, you may want to start a new thread to solve this problem. It will be more visible. And I dont think it belongs here anyways, because it's not really related to the problem discussed before. (If you feel, we are apt to provide you with the information you need, you can of course post here, too)

Good luck,
- drowstar
 
Old 12-26-2004, 06:40 PM   #11
eneville
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Re: thx

Quote:
Originally posted by yakuzay
an apt-get install libmikmod2 worked fine for me :-)

thx
Thanks that works great here. Odly, I've never experienced this problem in all my YEARS of using X11Amp!

Happy holidays and have a good new year.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XMMS Error Centinul Linux - Software 3 06-26-2005 08:35 PM
xmms error simeandrews Mandriva 1 04-26-2005 02:33 AM
xmms error subaruwrx Debian 1 12-19-2004 12:33 AM
xmms error chrismiceli Linux - General 2 04-25-2004 10:33 PM
XMMS Error true_atlantis Linux - Newbie 7 11-03-2003 04:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration