LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-11-2016, 02:44 PM   #1
Riposte
LQ Newbie
 
Registered: Jul 2016
Posts: 2

Rep: Reputation: Disabled
Xlib extension GLX missing on display ":0.0" when running SDL with OpenGL


I'm trying to run a program I made which uses SDL and I am getting an error at the start. Full output:

Code:
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
thread '<main>' panicked at 'Failed to create window: SDL error: GLX is not supported', src/main.rs:32
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Xlib:  extension "GLX" missing on display ":0.0".
error: Process didn't exit successfully: `target/debug/chip8_emulator` (exit code: 101)
I think when I set up Linux a couple months ago I may have made a bit of a mess with my drivers, but I'm not sure and don't know where to go from here.
Some details about my system:
  • OS: Debian Jessie, 64-bit
  • CPU: Intel Core i7
  • Graphics: Nvidia GeForce GT

Output from my Xorg.0.log if that helps: http://pastebin.com/Uip9XkcX

Any help would be appreciated. (sorry if this is the wrong forum, this is my first post here and I wasn't sure where this problem best fit)
 
Old 07-11-2016, 04:19 PM   #2
Riposte
LQ Newbie
 
Registered: Jul 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
I installed mesa-utils as was suggested in another thread I found to run glxinfo and that continued to give me the same error. After that I ran nvidia-uninstall and removed my xorg.conf and that has stopped the error I was getting before at least so I'll mark this as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib error "extension "GLX" missing on display" Trivelt Linux - Virtualization and Cloud 0 09-02-2014 01:45 PM
Xlib: extension "GLX" missing on display ":0.0". jrk5050 Linux - Hardware 5 05-09-2008 12:19 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". HELP! badgerbox76 Linux - Newbie 35 03-08-2007 03:27 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". badgerbox76 Linux - Games 13 01-11-2006 05:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration