LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-21-2008, 04:56 AM   #1
bsk66
LQ Newbie
 
Registered: Dec 2008
Location: india
Posts: 5

Rep: Reputation: 0
Question Xlib


when trying to run a graphical application at a remote host i get the error
Xlib: 'connection to ":0.0" refused by server'
Xlib: No protocol specified
How to address this?
 
Old 12-21-2008, 08:38 AM   #2
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 510

Rep: Reputation: 53
Usally, you'd have to start it with yourapp --display host:0 - this looks like this:

blahblah --display 127.0.0.1:0

or similar (check the help of yourapp - sometimes it's --display= or -display and so on).

And the remote host has to actually allow X apps to be started from remote.

See man xhost for details.

(And check the firewall settings or it may be only allowed to start x apps via ssh - there are many possibilities why exactly starting your app might fail.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Linux - Newbie 12 11-27-2018 01:30 PM
Xlib: connection to ":0.0" refused by server Xlib: No protocol ... ousoso@webmail.co.za Linux - Newbie 1 05-06-2008 07:46 AM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified rajnivanza Linux - Software 1 03-13-2008 01:16 PM
xlib mirsoft Programming 2 10-16-2007 02:32 AM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Programming 1 03-02-2004 08:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration