Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-26-2005, 02:04 AM   #1
LQ Newbie
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Xkb: How to configure Multipurpose Dead Keys?

Hello. I'm looking for a help with XKB configuration.

I'm creating new keyboard layout (for be-latn) and have encountered a few problems...

I need to configure a dead key which won't be just the single symbol dead key (like dead_acute, which always applies acute accent), but variable one. I mean, I want it to apply acute to some letters, caron to other ones, and stroke to third ones.

For example, if I press ~c I need to get č (c-caron), but if I press ~u I need to get ŭ (u-breve), and if I press ~l I need to get ł (l-stroke).

Is there any way to configure this in symbols configuration file of XKB?

Thank you!
Old 10-26-2005, 06:57 PM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Perhaps this tutorial will help.

Or, perhaps this HOWTO .

Hope these help.
Old 10-31-2005, 07:31 AM   #3
Registered: Sep 2004
Posts: 63

Rep: Reputation: 15
Hi Monk15,
the "dead key" technique is generally a big nuisance, because to obtain exactly the dead key you are obliged to press it twice
(or dead key + blank). I make an example to clarify:
Being Italian (but using a USA keyboard) in writing I use apostrophe a lot (').
But this key is generally used as a dead key (dead_acute).
If I want the apostrophe I am obliged to use ' + blank if not the starting vowel of the following word takes an acute accent!
Being also a newbye programmer I have big problems with strings...
So I found another solution. Unfortunately it works only if your distribution
enables the Alt key on the right to produce various symbols (also those you are looking for).
Look at my post:
In this post, having switched to Ubuntu, my method doesn't work any more
and that is the reason of the help request (no answers).
But if you have the Alt key enabled... let me know and we'll manage to
make your keyboard working without dead keys!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
XKB: Configuring multipurpose dead keys Monk15 Linux - Software 0 10-20-2005 04:13 PM
Dead keys not working on X client-server Sibidi Linux - Software 2 03-06-2005 04:56 AM
Dead keys or diacritic in OpenOffice - solution jlinkels Linux - Software 1 02-16-2005 10:26 AM
Dead F-Keys in X cothrige Linux - Newbie 7 05-10-2004 03:34 AM
Slackware + dead keys + openoffice ccool Slackware 8 02-18-2004 09:58 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:30 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration