LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-10-2004, 04:26 PM   #1
ftgow
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 69

Rep: Reputation: 15
xinit command


I have a couple applications that I need to run in a seperate X session.

To test out the xinit command, I run xinit xterm -- :1

A new X session opens up on vt08 and I can switch in and out of it, but xterm does not load up, neither does any program I try. All I get is a big X cursor and a black screen. I can move hte cursor.

What am I doing wrong? I did not modify xf86conig for any screen or layout, settings, as I dont know what the hell im doing inthere.

PLease help me.
 
Old 06-10-2004, 05:31 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914
If you terminate the session you'll probably find something like:
Quote:
xterm: bad command line option "xterm"

usage: xterm [-/+132] [-C] [-Sccn] [-T string] [-/+ah] [-/+ai] [-/+aw]
[-b number] [-/+bc] [-bcf milliseconds] [-bcn milliseconds] [-bd color]
in the output ...

To me that indicates that either xterm or, more likely, xinit in this
version is stuffed as it appears to hand xterm as a parameter to itself.


If you just want X with a xterm without any wm-decorations you can
create a file

~/.xserverrc
X :1

and then run
xinit -- :1
which will give you exactly that.



Cheers,
Tink
 
Old 06-10-2004, 06:01 PM   #3
ftgow
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 69

Original Poster
Rep: Reputation: 15
I get this as output


This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.5-gentoo-r1 i686 [ELF]
Build Date: 08 June 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.1.log", Time: Thu Jun 10 17:59:25 2004
(==) Using config file: "/etc/X11/XF86Config"
Using vt 8
(II) Initializing extension GLX
AUDIT: Thu Jun 10 17:59:27 2004: 9100 X: client 1 rejected from local host
Xlib: connection to ":1.0" refused by server
Xlib: No protocol specified


waiting for X server to begin accepting connections .
AUDIT: Thu Jun 10 17:59:29 2004: 9100 X: client 1 rejected from local host
Xlib: connection to ":1.0" refused by server
Xlib: No protocol specified

..
AUDIT: Thu Jun 10 17:59:31 2004: 9100 X: client 1 rejected from local host
Xlib: connection to ":1.0" refused by server
Xlib: No protocol specified

..
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.
ftgow@trioptimum ftgow $
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xinit X problem BattousaiX Linux - Software 2 01-31-2012 05:08 PM
Kdrive and xinit slothpuck Linux - Software 0 01-24-2005 02:50 PM
confused about which xinit to use Earth Slackware 3 07-20-2004 12:14 AM
question about XINIT evaross1 Linux - Software 3 05-12-2004 04:00 AM
mozilla + xinit vapz Linux - Software 0 07-09-2003 03:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration