LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-11-2005, 12:17 PM   #1
AVD_ZM
Member
 
Registered: Oct 2004
Location: HELLAS aka Greece
Distribution: K/Ubuntu Knoppel
Posts: 114

Rep: Reputation: 15
xine, problem compiling the UI


Hey,

as i understood first you compile the lib
which i've done with no errors
n install

then u compile the ui.
now
i type ./configure
it brings up an error saying that i should install
the lib first.

which i have.

i'm using xine-lib1 n xine-ui-993.

any ideas???
 
Old 02-11-2005, 03:02 PM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

add ths line to /etc/ld.so.conf

/usr/local/lib

and save and exit

then run

ldconfig

and again try to compile ur UI

regards
 
Old 02-11-2005, 07:12 PM   #3
AVD_ZM
Member
 
Registered: Oct 2004
Location: HELLAS aka Greece
Distribution: K/Ubuntu Knoppel
Posts: 114

Original Poster
Rep: Reputation: 15
/usr/local/lib is there.

some reason i don't have ldconfig
where can i find it? or download
 
Old 02-11-2005, 08:58 PM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
ldconfig is only available to root coz it's in /sbin. To run it you need to do /sbin/ldconfig or if you have full root privileges and paths then you just run it as "ldconfig"
 
Old 02-21-2005, 06:21 AM   #5
grato
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
xine and ldconfig

hi *,

i have a rpoblem related to the above. after successfully compiling and installing xine, i tried ldconfig. i got the error message ldconfig: /usr/local/lib/ld.so.conf is not an ELF file - it has the wrong magic bytes at the start.

additional information: logged in as root, ld.conf.so contains /usr/local/lib

any help with that is appreciated.

thanks in advance!
 
Old 02-21-2005, 06:23 AM   #6
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
what is in /usr/local/lib/ld.so.conf ( did you put it there?)?
 
Old 02-21-2005, 07:10 AM   #7
grato
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
hi,

ld.so.conf:


/usr/X11R6/lib/Xaw95
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/i486-linux/lib
/usr/i486-linux/libc5/lib=libc5
/usr/i486-linux/libc6/lib=libc6
/usr/i486-linuxaout/lib
/usr/i386-suse-linux/lib
/usr/local/lib
/usr/openwin/lib
/opt/kde/lib
/opt/kde2/lib
/opt/kde3/lib
/opt/gnome/lib
/opt/gnome2/lib

include /etc/ld.so.conf.d/*.conf

i didn't put it there.

thanks for your help.
 
Old 02-21-2005, 07:12 AM   #8
grato
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
sorry, my mistake.

i copied ld.do.conf to /usr/local/lib/ . so it is the same file.
 
Old 02-21-2005, 03:26 PM   #9
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you just need the one in /etc, remove the ld.so.conf in /usr/local/lib and re-run ldconfig. if you did a ./configure, make, make install on xine-lib the libraries will be in /usr/local/lib. just run ldconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xine, problem compiling, wronf format error AVD_ZM Linux - Software 1 03-07-2005 05:16 AM
Problems compiling xine BU5T4 Linux - Software 3 01-27-2005 05:04 PM
Strange Xine problem - Xine running fine only in Xnest xgreen Slackware 3 01-24-2005 10:00 AM
compiling xine on slackware 10 Villain Linux - Software 3 09-17-2004 08:39 AM
xine.de is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration