LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-08-2006, 04:46 AM   #1
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Rep: Reputation: 30
Xine-lib make error


I am tring to compile Xine because I am having trouble playing dvd's. The picture doesn't match up with the sound and I get an error saying "Loosing to many frames, your system is to slow" or somthing like that.
Anyways, I am am getting an error when trying to make the xine-lib:

Quote:
image.c:46:30: wand/magick_wand.h: No such file or directory
image.c: In function `image_decode_data':
image.c:86: error: `MagickBooleanType' undeclared (first use in this function)
image.c:86: error: (Each undeclared identifier is reported only once
image.c:86: error: for each function it appears in.)
image.c:86: error: syntax error before "status"
image.c:87: error: `MagickWand' undeclared (first use in this function)
image.c:87: error: `wand' undeclared (first use in this function)
image.c:95: warning: implicit declaration of function `NewMagickWand'
image.c:95: warning: nested extern declaration of `NewMagickWand'
image.c:96: error: `status' undeclared (first use in this function)
image.c:96: warning: implicit declaration of function `MagickReadImageBlob'
image.c:96: warning: nested extern declaration of `MagickReadImageBlob'
image.c:99: error: `MagickFalse' undeclared (first use in this function)
image.c:100: warning: implicit declaration of function `DestroyMagickWand'
image.c:100: warning: nested extern declaration of `DestroyMagickWand'
image.c:105: warning: implicit declaration of function `MagickGetImageWidth'
image.c:105: warning: nested extern declaration of `MagickGetImageWidth'
image.c:106: warning: implicit declaration of function `MagickGetImageHeight'
image.c:106: warning: nested extern declaration of `MagickGetImageHeight'
image.c:108: warning: implicit declaration of function `MagickGetImagePixels'
image.c:108: warning: nested extern declaration of `MagickGetImagePixels'
image.c:108: error: `CharPixel' undeclared (first use in this function)
image.c:109: warning: nested extern declaration of `DestroyMagickWand'
make[2]: *** [xineplug_decode_image_la-image.lo] Error 1
make[2]: Leaving directory `/home/nate/programs/xine/xine-lib-1.1.1/src/libxinevdec'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/home/nate/programs/xine/xine-lib-1.1.1/src'
make: *** [check-recursive] Error 1
Does anyone know why I am getting this error?
 
Old 04-08-2006, 04:50 AM   #2
coolb
Member
 
Registered: Apr 2006
Location: Cape Town, South Africa
Distribution: Gentoo 2006.1(2.6.17-gentoo-r7)
Posts: 222

Rep: Reputation: 30
You using CentOS??

Did you try a binary for Xine?
 
Old 04-08-2006, 05:20 AM   #3
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Yes.

And yes.

I installed xine, mplayer, ogle, and libdvdcss with yum. Maybe I should try and compile libdvdcss?

Whats weird is ogle can handle dvd's better than mplayer and xine. The sound is just barely off time with the picture.
 
Old 04-08-2006, 05:58 PM   #4
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Ok, installing from source didn't help. When I enable framedroping with mplayer it does work better, but not perfect. When I click on fullscreen it takes up about half of the screen.

I would like to try hdparm but I can't seem to install it. I tried yum and source with no errors but still nothing.
Quote:
$ hdparm
bash: hdparm: command not found
Ok, its /sbin/hdparm

Last edited by natewlew; 04-08-2006 at 06:59 PM.
 
Old 04-09-2006, 05:42 PM   #5
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
I have fixed my problem. I was using the vesa driver with my Sis 315 card. CentOS has an easy way to change the Vesa to the Sis driver. System settings>>Display>>Hardware(Tab)>>>Configure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xine gui install doesn't find xine-lib blackdragonblood Linux - Software 5 02-10-2006 07:19 PM
xine-lib make/instaling error espo111 Linux - Software 3 07-23-2005 12:45 PM
Make error with xine-ui Levitate Linux - Software 2 02-14-2005 09:00 AM
Configure error on xine-lib-rc8 linux-rulz Linux - Software 12 12-24-2004 04:57 AM
xine.de is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration